Bug 867071 - NameError: global name 'anaconda' is not defined
NameError: global name 'anaconda' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:cc5d05a4b8d49254a9f92b26548...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Betappc
  Show dependency treegraph
 
Reported: 2012-10-16 13:15 EDT by Jesse Keating
Modified: 2013-01-09 22:36 EST (History)
13 users (show)

See Also:
Fixed In Version: anaconda-18.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 14:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: release (24 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: product (6 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: type (9 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: storage.log (112.86 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: version (2 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: environ (835 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: anaconda.log (4.71 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: syslog (61.51 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: packaging.log (37.74 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: cmdline_file (282 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: ks.cfg (755 bytes, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: anaconda-tb (312.59 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
File: program.log (42.83 KB, text/plain)
2012-10-16 13:15 EDT, Jesse Keating
no flags Details
anaconda-tb-iUHPTS (18.17) (1.24 MB, text/plain)
2012-10-17 02:39 EDT, Steve Tyler
no flags Details

  None (edit)
Description Jesse Keating 2012-10-16 13:15:18 EDT
Description of problem:
Kickstart using an updates.img from all the commits as of the morning of Oct 16th.

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/bootloader.py", line 2143, in writeSysconfigKernel
:    if anaconda.id.bootloader.trusted_boot:
:  File "/tmp/updates/pyanaconda/bootloader.py", line 2186, in writeBootLoader
:    writeSysconfigKernel(storage, version)
:  File "/tmp/updates/pyanaconda/install.py", line 127, in doInstall
:    writeBootLoader(storage, payload, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/tmp/updates/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:NameError: global name 'anaconda' is not defined
Comment 1 Jesse Keating 2012-10-16 13:15:20 EDT
Created attachment 628278 [details]
File: release
Comment 2 Jesse Keating 2012-10-16 13:15:22 EDT
Created attachment 628279 [details]
File: product
Comment 3 Jesse Keating 2012-10-16 13:15:23 EDT
Created attachment 628280 [details]
File: type
Comment 4 Jesse Keating 2012-10-16 13:15:25 EDT
Created attachment 628281 [details]
File: storage.log
Comment 5 Jesse Keating 2012-10-16 13:15:28 EDT
Created attachment 628282 [details]
File: version
Comment 6 Jesse Keating 2012-10-16 13:15:29 EDT
Created attachment 628283 [details]
File: environ
Comment 7 Jesse Keating 2012-10-16 13:15:30 EDT
Created attachment 628284 [details]
File: anaconda.log
Comment 8 Jesse Keating 2012-10-16 13:15:32 EDT
Created attachment 628285 [details]
File: syslog
Comment 9 Jesse Keating 2012-10-16 13:15:33 EDT
Created attachment 628286 [details]
File: hashmarkername
Comment 10 Jesse Keating 2012-10-16 13:15:35 EDT
Created attachment 628287 [details]
File: packaging.log
Comment 11 Jesse Keating 2012-10-16 13:15:36 EDT
Created attachment 628288 [details]
File: cmdline_file
Comment 12 Jesse Keating 2012-10-16 13:15:38 EDT
Created attachment 628289 [details]
File: ks.cfg
Comment 13 Jesse Keating 2012-10-16 13:15:44 EDT
Created attachment 628290 [details]
File: anaconda-tb
Comment 14 Jesse Keating 2012-10-16 13:15:46 EDT
Created attachment 628291 [details]
File: program.log
Comment 15 Jesse Keating 2012-10-16 14:58:25 EDT
Already fixed upstream.
Comment 16 Steve Tyler 2012-10-17 02:39:48 EDT
Created attachment 628549 [details]
anaconda-tb-iUHPTS (18.17)

Exception while installing bootloader.
Comment 17 Dan Mashal 2012-10-17 04:45:48 EDT
hit this on smoke 10.. im guessing smoke 11 will hopefully not have this issue.
Comment 18 Steve Tyler 2012-10-17 08:21:30 EDT
$ pylint -E ./anaconda-18.16-1/pyanaconda/bootloader.py | grep anaconda
No config file found, using default configuration

$ pylint -E ./anaconda-18.17-1/pyanaconda/bootloader.py | grep anaconda
No config file found, using default configuration
E:2143,7:writeSysconfigKernel: Undefined variable 'anaconda'

$ rpm -q pylint
pylint-0.25.1-1.fc17.noarch
Comment 19 Steve Tyler 2012-10-17 08:25:09 EDT
$ diff -u ./anaconda-18.16-1/pyanaconda/bootloader.py ./anaconda-18.17-1/pyanaconda/bootloader.py
--- ./anaconda-18.16-1/pyanaconda/bootloader.py	2012-10-11 17:37:40.000000000 -0700
+++ ./anaconda-18.17-1/pyanaconda/bootloader.py	2012-10-16 17:09:34.000000000 -0700
@@ -2140,6 +2140,10 @@
     f.write("\n")
     f.write("# DEFAULTKERNEL specifies the default kernel package type\n")
     f.write("DEFAULTKERNEL=%s\n" % kernel)
+    if anaconda.id.bootloader.trusted_boot:
+        f.write("# HYPERVISOR specifies the default multiboot kernel\n")
+        f.write("HYPERVISOR=/boot/tboot.gz\n")
+        f.write("HYPERVISOR_ARGS=logging=vga,serial,memory\n")
     f.close()
 
 def writeBootLoader(storage, payload, instClass):
Comment 20 Steve Tyler 2012-10-17 09:36:22 EDT
[RHEL 6] Configure new-kernel-pkg to keep tboot configuration on updates (#742885)
https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-October/001643.html
Comment 21 Tim Flink 2012-10-17 11:14:01 EDT
I did a minimal install on an x86_64 VM using the smoke10 test image and saw this during "performing post-install setup tasks"

Package: anaconda-18.17
OS Release: Fedora release 18
Comment 22 Adam Williamson 2012-10-17 13:16:08 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . This bug seems to be back in 18.17 and affecting straight-through installs, so it is accepted as a Beta blocker under criterion "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data" and we're setting it back to ASSIGNED.
Comment 23 satellitgo 2012-10-17 18:27:17 EDT
install of Mate desktop with netinstall smoke10 x86_64 failed at installin bootloader

Package: anaconda-18.17
OS Release: Fedora release 18
Comment 24 Chris Lumens 2012-10-17 19:16:30 EDT
Fixed by 2f79819d26eb481487ab338a0d211d70d79c6ac4.
Comment 25 Steve Tyler 2012-10-17 21:33:50 EDT
There is no anaconda object available in writeSysconfigKernel

This change was introduced in commit c308c8978e2d27 that is a port from rhel6-branch where we use anaconda.id.bootloader instead of storage.bootloader. 

http://git.fedorahosted.org/cgit/anaconda.git/commit/?id=2f79819d26eb481487ab338a0d211d70d79c6ac4
Comment 26 Adam Williamson 2012-10-24 14:41:35 EDT
Discussed at the 2012-10-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-24/f18beta-blocker-review-5.2012-10-24-16.01.log.txt .

As we read this the bug has been fixed since at least 18.18 (the date on the commit is prior to 18.18 being built) and no new reports of this have been seen with TC5 or TC6, despite multiple people doing tests that would be expected to hit this bug. 18.19 is stable. Hence we can close this bug. It can be re-opened if anyone hits it again.

Note You need to log in before you can comment on or make changes to this bug.