Bug 867075 - Impossible to enter a pool of IP addresses in ettercap's DHCP spoofing menu
Impossible to enter a pool of IP addresses in ettercap's DHCP spoofing menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ettercap (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 13:24 EDT by Éric Bischoff
Modified: 2012-12-20 10:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:39:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the issue (445 bytes, patch)
2012-10-16 13:24 EDT, Éric Bischoff
no flags Details | Diff

  None (edit)
Description Éric Bischoff 2012-10-16 13:24:33 EDT
Created attachment 628307 [details]
Patch fixing the issue

Description of problem:

Ettercap has a GTK graphical mode. In this mode, the DHCP spoofing menu entry does not work as expected.

Version-Release number of selected component (if applicable):

ettercap-0.7.5-1.fc17.1.20120906gitc796e5.x86_64

How reproducible:

In Fedora core 17, ask for DHCP spoofing in Ettercap GUI.

Steps to Reproduce:
1. yum install ettercap
2. ettercap -G   (as root)
3. In the menus, select Sniff => Unified sniffing
4. Select your network interface card
5. In the menus, select MITM => DHCP spoofing
6. Enter a valid IP address in the first field
7. Enter the network mask in the second field
8. Enter the address of a DNS server in the third field
9. Press OK button
  
Actual results:

Message "DHCP spoofing: parameter number 1 is incorrect" appears, followed by "Incorrect number of tokens (///) in TARGET!"

Expected results:

No error message should appear, but a message that spoofing has been set up should appear in the messages log in lower part of main window.

Additional info:

A fix is attached to this bug report, inspired from ettercap's online GIT repository. It has been tested with rpmbuild and works.

Also, are you sure that it is really the 0.7.5 version of ettercap that is packaged? Strangely enough, the tarball in the source package is numbered 0.7.4.1. But it might just be misnamed, because "ettercap -v" returns the correct 0.7.5 release number.
Comment 1 Gwyn Ciesla 2012-10-16 16:07:18 EDT
Thanks for the patch.  The tarball is in fact misnamed. :)

I'll get this out ASAP.
Comment 2 Fedora Update System 2012-10-16 16:22:26 EDT
ettercap-0.7.5-2.fc18.1.20120906gitc796e5 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-2.fc18.1.20120906gitc796e5
Comment 3 Fedora Update System 2012-10-16 16:23:01 EDT
ettercap-0.7.5-2.fc17.1.20120906gitc796e5 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ettercap-0.7.5-2.fc17.1.20120906gitc796e5
Comment 4 Fedora Update System 2012-10-16 23:18:15 EDT
Package ettercap-0.7.5-2.fc18.1.20120906gitc796e5:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ettercap-0.7.5-2.fc18.1.20120906gitc796e5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16287/ettercap-0.7.5-2.fc18.1.20120906gitc796e5
then log in and leave karma (feedback).
Comment 5 Éric Bischoff 2012-10-17 05:43:12 EDT
Thank you Jon. This was responsive :-). I'll test the fixed RPM ASAP.

Please notice that the next upstream version of ettercap might not have the bug. I'm saying this because I have not seen the wrong strncpy() instruction in their online Git repository, which I suppose is the latest version. So you might need to drop my patch once you resynchronize with them.
Comment 6 Gwyn Ciesla 2012-10-17 07:56:03 EDT
I'll watch for it.  If not, the patch won't apply, in which case I'll doube check and likely drop it.
Comment 7 Éric Bischoff 2012-10-19 04:14:11 EDT
Package still not online. Did you notice I was in Fedora Core 17?
Comment 8 Gwyn Ciesla 2012-10-19 06:56:07 EDT
It's in updates-testing.
Comment 9 Emilio A. Escobar 2012-10-22 22:08:22 EDT
This bug was fixed in our latest release of Ettercap 0.7.5, I believe Fedora is being changed to use our GitHub repository as upstream. Is this not the case?

Thanks,

Emilio
Comment 10 Gwyn Ciesla 2012-10-22 22:17:08 EDT
Yes, in fact 0.7.5 is on it's way to updates-testing, but we're still using the SF.net tarball release.
Comment 11 Emilio A. Escobar 2012-10-23 09:41:03 EDT
That's ok, the 0.7.5 tarball on SF.net is the same one hosted at GitHub.

Thanks!
Comment 12 Fedora Update System 2012-12-20 10:39:40 EST
ettercap-0.7.5-2.fc18.1.20120906gitc796e5 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.