Bug 867080 - Seam booking, seamspace: Broken ant scripts (unclosed version strings, bad dom4j version)
Seam booking, seamspace: Broken ant scripts (unclosed version strings, bad do...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam 2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 14:08 EDT by Ron Šmeral
Modified: 2016-10-31 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Šmeral 2012-10-16 14:08:50 EDT
Description of problem:
There's a typo in the ant script of all modules (ear, ejb, tests, web). 
The value of the version attribute is unclosed -- it misses the right quotation mark.
The positions are: 
- booking-ear/build.xml:43, 
- booking-ejb/build.xml:58, 
- web/build.xml:45, 
- web/build.xml:48, 
- tests/build.xml:45, 
- tests/build.xml:52.

After fixing this, calling "ant clean package" in the example's directory fails with missing dependency: org.jboss.seam:bom:pom:2.3.0.Final-redhat-1, even though this dependency is present in the jboss-wfk-repository. (Only after calling "mvn clean package" first, the "ant clean package" finds the missing dependency.)

Also, in booking-ejb, the dependency dom4j has version 1.6.1-brew, which can't be found in any of the relevant repositories (central, jboss-wfk-repository, jboss-eap6-repository).


Version-Release number of selected component (if applicable):
2.3.0.Final-redhat-1


Steps to Reproduce:
1. Download and properly unpack 
- jboss-wfk-2.1.0.ER2-seam23-bin.zip, 
- jboss-wfk-2.1.0.ER2-seam23-demo.zip, 
- jboss-wfk-2.1.0.ER2-maven-repository.zip, 
- jboss-eap-6.0.0-maven-repository.zip.

2. Run "ant clean package" in jboss-wfk-2.1.0.ER2/jboss-seam-2.3.0.Final-redhat-1/examples/booking.

Actual results:
The build fails.

Expected results:
The build should pass and produce seam-booking.ear
Comment 1 Ron Šmeral 2012-10-18 09:13:23 EDT
There's another problem, with the Ant build script. If the zips (bin, demo) are unpacked in the same folder, the Ant build complains about missing build.lib.classpath, which points to ${root.dir}/build/lib, where root.dir points to "../../..". 
This is not very safe, since it only works once the 'examples' dir is moved to the unpacked Seam home. This is, however, not documented anywhere. 
A safer solution (instead of the root.dir) would be to introduce a seam.home variable which would have to be set to the Seam home directory and this would be documented in the appropriate readme.txt file.
Comment 2 Marek Schmidt 2012-10-19 09:11:04 EDT
Note that similar problems are also in the seamspace example, which also contains ant build files.
Comment 3 Marek Novotny 2012-11-05 11:54:17 EST
I have removed scripts from seamspace example
Comment 5 Karel Piwko 2012-11-30 10:34:58 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.