Bug 867121 - Release Note required for Deprication Warning
Release Note required for Deprication Warning
Status: CLOSED CURRENTRELEASE
Product: CloudForms Common
Classification: Red Hat
Component: Docs Release Notes (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: beta6
: ---
Assigned To: Julie
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 16:00 EDT by Chris Pelland
Modified: 2012-12-10 17:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
In a deployable XML document, the "parameter" XML element indicates a piece of information passed to a configuration script for a launching instance. Each parameter may be either a reference parameter or a launch-time parameter. Reference parameters collect their value from another launching instance in the same deployment. Launch-time parameters require the person launching the deployment to provide the value via Conductor. In Conductor, the "type" attribute (previously associated with the parameter XML element) indicates the type of value the individual must provide when launching the deployment. Conductor uses the type attribute to know which HTML field to present to the user during the launch process. For instance, a "password" type indicates that Conductor should display an HTML password field, so as to hide the entered value in the display (NOTE: Currently only "scalar" and "password" types are supported). In Conductor 1.1, the "type" attribute has been moved from the parameter XML element to the value XML element. This more accurately reflects the notion that only launch-time parameters require a "type" to be set, because reference parameters inherit their type from the launching instance providing the value for parameter. A deployable with a type attribute on a parameter XML element will produce the following warning: "Deprecation Warning: Parameter '<parameter name>' in service '<service name>' has a type attribute. Remove the type attribute or move it to a child value tag." To remedy this, the deployable maintainer can either remove the type attribute from the parameter XML element, or move the type attribute from the parameter XML element to the value XML element nested inside the parameter. NOTE: If the deployable maintainer chooses to remove the type attribute (and not move it to the value XML element), Conductor will assume that the HTML field type should be a standard text input field. Example 1: Deprecated parameter block <parameter type="scalar" name="Parameter1"> <value>Default</value> </parameter> Example 2: Fix by removing type attribute <parameter name="Parameter1"> <value>Default</value> </parameter> Example 3: Fix by moving the type attribute to the value element <parameter name="Parameter1"> <value type="scalar">Default</value> </parameter>
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 17:01:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot of Deprication Warning (69.47 KB, image/png)
2012-10-16 16:00 EDT, Chris Pelland
no flags Details

  None (edit)
Description Chris Pelland 2012-10-16 16:00:18 EDT
Created attachment 628364 [details]
Screen Shot of Deprication Warning

When a user uses services that have "type=" and they save their blueprint, 
they will see the warnings in the attached screenshot. 

We should have a release note that explains why it's being depreciated and provides an example of how to change a blueprint that was using it to fit the new mode of operation.
Comment 1 Julie 2012-10-17 00:29:06 EDT
in 1.O application blueprint template: 
<service>
...
 <parameter name="param-1" type="scalar">
...
</service>

in 1.1 application blueprint template: 
<service>
...
 <parameter name="param-1">
              <value type="scalar">default_text</value>
 </parameter>
...
</service>

Q1: Does both templates evoke warnings?
Q2: Need more info on why "type=" is deprecated. 

Thanks,
Julie
Comment 2 Greg Blomquist 2012-10-17 08:46:12 EDT
Added DocText.

Please let me know if any of that in unclear, and we can figure out how to provide more information.
Comment 7 Lana Brindley 2012-12-10 17:01:53 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.