Bug 867149 - [abrt] gnome-boxes-3.6.1-1.fc18: strlen: Process /usr/libexec/gnome-boxes-search-provider was killed by signal 11 (SIGSEGV)
[abrt] gnome-boxes-3.6.1-1.fc18: strlen: Process /usr/libexec/gnome-boxes-sea...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-boxes (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
abrt_hash:45d658a7bc1f049e562dba72411...
:
: 868186 872970 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 17:41 EDT by Andreas Lorensen
Modified: 2012-11-23 02:47 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:47:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.15 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: environ (1010 bytes, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: backtrace (12.16 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: cgroup (128 bytes, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: maps (6.96 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: dso_list (2.17 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: build_ids (1.04 KB, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: var_log_messages (706 bytes, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: open_fds (294 bytes, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
File: proc_pid_status (783 bytes, text/plain)
2012-10-16 17:41 EDT, Andreas Lorensen
no flags Details
Fix (2.32 KB, patch)
2012-10-23 14:16 EDT, Alexander Larsson
no flags Details | Diff

  None (edit)
Description Andreas Lorensen 2012-10-16 17:41:05 EDT
Version-Release number of selected component:
gnome-boxes-3.6.1-1.fc18

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.15
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-boxes-search-provider
crash_function: strlen
kernel:         3.6.1-1.fc18.i686

truncated backtrace:
:Thread no. 1 (8 frames)
: #0 strlen at ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S:50
: #1 g_strdup at gstrfuncs.c:363
: #2 boxes_search_provider_GetResultMetas_co at /extra-data/checkout/gnome/gnome-boxes/src/gnome-boxes-search-provider.vala:116
: #3 g_simple_async_result_complete at gsimpleasyncresult.c:775
: #4 complete_in_idle_cb_for_thread at gsimpleasyncresult.c:843
: #9 g_main_context_iteration at gmain.c:3351
: #10 g_application_run at gapplication.c:1620
: #11 _vala_main at /extra-data/checkout/gnome/gnome-boxes/src/gnome-boxes-search-provider.vala:197
Comment 1 Andreas Lorensen 2012-10-16 17:41:08 EDT
Created attachment 628419 [details]
File: core_backtrace
Comment 2 Andreas Lorensen 2012-10-16 17:41:11 EDT
Created attachment 628420 [details]
File: environ
Comment 3 Andreas Lorensen 2012-10-16 17:41:13 EDT
Created attachment 628421 [details]
File: limits
Comment 4 Andreas Lorensen 2012-10-16 17:41:15 EDT
Created attachment 628422 [details]
File: backtrace
Comment 5 Andreas Lorensen 2012-10-16 17:41:17 EDT
Created attachment 628423 [details]
File: cgroup
Comment 6 Andreas Lorensen 2012-10-16 17:41:19 EDT
Created attachment 628424 [details]
File: maps
Comment 7 Andreas Lorensen 2012-10-16 17:41:21 EDT
Created attachment 628425 [details]
File: dso_list
Comment 8 Andreas Lorensen 2012-10-16 17:41:23 EDT
Created attachment 628426 [details]
File: build_ids
Comment 9 Andreas Lorensen 2012-10-16 17:41:24 EDT
Created attachment 628427 [details]
File: var_log_messages
Comment 10 Andreas Lorensen 2012-10-16 17:41:26 EDT
Created attachment 628428 [details]
File: open_fds
Comment 11 Andreas Lorensen 2012-10-16 17:41:28 EDT
Created attachment 628429 [details]
File: proc_pid_status
Comment 12 Christophe Fergeau 2012-10-17 06:45:28 EDT
/extra-data/checkout/gnome/gnome-boxes/src/gnome-boxes-search-provider.vala:116 is foreach (var id in ids), and vala indeed generates a g_strdup when doing the iteration. As g_strdup handles NULL string, this probably means we ended up with an invalid string in this list.
I couldn't spot something wrong in there though :( Any chance you can catch this crash in valgrind?
Comment 13 Andreas Lorensen 2012-10-17 08:04:28 EDT
Any chance you can catch this crash in valgrind?

I dont know what that means :( I am new to fedora and new on repporting bugs.
Comment 14 Christophe Fergeau 2012-10-17 08:23:41 EDT
Ok, never mind then, thanks for the bug report and your answer ;) Is it an issue you can reproduce whenever you want, or did it occur only once?
Comment 15 Andreas Lorensen 2012-10-17 08:44:59 EDT
I get it when I do a reboot. It started after latest update where gnome-boxes were updated.

I dosent seem to have any impact on my system, as it is working as usaual.
Comment 16 Andreas Lorensen 2012-10-17 11:52:42 EDT
Just updated gnome-boxes to 3.6.1.1-1.fc18 and no ABRT when rebooting.
Comment 17 Christophe Fergeau 2012-10-19 05:19:59 EDT
*** Bug 868186 has been marked as a duplicate of this bug. ***
Comment 18 Alexander Larsson 2012-10-23 14:16:22 EDT
Created attachment 632271 [details]
Fix
Comment 19 Christophe Fergeau 2012-10-24 08:25:20 EDT
+    /* We have to put this in a separate file because vala does not seem to honor "owned"

should be 'separate method'
Did I understand correctly that the issue is that we are calling async methods from the dbus callback, and that vala does not copy the callback arguments in this case, which means they don't stay alive for the whole duration of the async method calls, hence the use of 'owned' to force the copy? If yes, ACK, otherwise I'll have to go back reviewing ;)
Comment 20 Alexander Larsson 2012-10-25 04:07:14 EDT
> Did I understand correctly that the issue is that we are calling async methods 
> from the dbus callback, and that vala does not copy the callback arguments in 
> this case, which means they don't stay alive for the whole duration of the
> async method calls, hence the use of 'owned' to force the copy?

Yes, this is exactly the problem, which then gets extra complicated by a valac bug that makes calling methods with "owned" arguments not work in the generated dbus wrapper method.
Comment 21 Alexander Larsson 2012-10-25 04:11:49 EDT
Pushed to git, will be fixed in next minor release.
Comment 22 Christophe Fergeau 2012-11-12 09:23:30 EST
*** Bug 872970 has been marked as a duplicate of this bug. ***
Comment 23 Fedora Update System 2012-11-13 06:28:21 EST
gnome-boxes-3.6.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-boxes-3.6.2-1.fc18
Comment 24 Fedora Update System 2012-11-13 14:04:46 EST
Package gnome-boxes-3.6.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-boxes-3.6.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18091/gnome-boxes-3.6.2-1.fc18
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2012-11-23 02:47:56 EST
gnome-boxes-3.6.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.