Bug 867162 - festival-speechtools header installation is broken
festival-speechtools header installation is broken
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: festival (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthias Clasen
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 19:34 EDT by Rich Mattes
Modified: 2017-12-06 06:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:31:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Mattes 2012-10-16 19:34:05 EDT
Description of problem:
Attempting to build Fawkes in epel.  Fawkes uses the EST speech features.  The headers in all of the subdirectories of /usr/include/speech_tools contain a folder named EST containing more header files.  However, the headers in /usr/include/speech_tools expect headers to be directly in each subdirectory.

For example, the error:
/usr/include/speech_tools/EST_THash.h:48:36: error: instantiate/EST_THashI.h: No such file or directory

EST_THash.h expects EST_THashI.h to be in ./instantiate/ but it's really in ./instantiate/EST/instantiate/

Another example, the error:
/usr/include/speech_tools/EST_track_aux.h:132: error: 'EST_Relation' has not been declared

EST_track_aux.h includes "ling_class/EST_Relation.h"  However, EST_Relation.h is really located at ling_class/EST/EST_Relation.h

I think the all the extraneous subdirectories should be removed so that the headers are internally consistent and usable.

Faild build logs:
https://koji.fedoraproject.org/koji/taskinfo?taskID=4597083

Version-Release number of selected component (if applicable):
festival-speechtools-devel-1.2.96-18.el6

How reproducible:
Try building anything including festival/festival.h

Steps to Reproduce:
1. Install festival-devel
2. Create a file with the following:
#include <festival/festival.h>
int main (int argc, char *argv[])
{
  return 0;
}


3. Build with the following:
g++ -o ftest ftest.cc -I/usr/include/festival
  
Actual results:
Build failure, missing several headers

Expected results:
no errors.

Additional info:
Comment 3 RHEL Product and Program Management 2013-10-13 20:22:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Jan Kurik 2017-12-06 06:31:27 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.