This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 867179 - ESXi5.1.0 guest RHEL7 boot with wrong grub interface
ESXi5.1.0 guest RHEL7 boot with wrong grub interface
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Peter Jones
Martin Banas
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 21:19 EDT by Bian Jinwei
Modified: 2014-06-13 05:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:43:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wrong_grub_interface (111.34 KB, image/png)
2012-10-16 21:19 EDT, Bian Jinwei
no flags Details

  None (edit)
Description Bian Jinwei 2012-10-16 21:19:44 EDT
Created attachment 628487 [details]
wrong_grub_interface

Description of problem:
Install guest RHEL7 with kernel-3.6.0-0.28.el7(x86_64) on ESXi5.1,after finished installation,reboot with a keystroke to edit the grub,then with a wrong grub interface(details in attachment),cannot edit the guest kernel.

Version-Release number of selected component (if applicable):
ESXi:ESXi5.1.0
ESXi guest:RHEL7 with kernel-3.6.0-0.28.el7(x86_64)

How reproducible:
100%

Steps to Reproduce:
1.Install the RHEL7 with kernel-3.6.0-0.28.el7(x86_64) on ESXi
2.Reboot the guest
3.by a kerstroke to trigger the grub edit

Actual results:
After a kerstroke,it will provide a wrong grub interface(details in attachment).


Expected results:
Can using the grub to edit the guest kernel.

Additional info:
On the version RHEL7 with kernel-3.3.0-0.20.el7 has no this issue.It might be a regression bug.
Comment 4 Bian Jinwei 2012-12-19 02:56:47 EST
The issue is not any more blocker.As you can enter into the target esxi vm kde desktop by installing the package below when you manually install the rhel7:
<1>x window system
<2>kde desktop

But the grub still in wrong interface status.
Comment 10 Qin Guan 2013-01-22 02:15:28 EST
Just confirmed that the grub menu shows up and could be edit when the RHEL7 guest booting up with the updated grub2 package.

ESXi: ESXi5.1.0
Guest: RHEL-7.0-20130120.0 (3.7.0-0.32.el7.x86_64)

The grub packages using for testing are:
grub2-2.00-15.el7.x86_64
grubby-8.22-1.el7.x86_64
grub2-tools-2.00-15.el7.x86_64
Comment 14 Ludek Smid 2014-06-13 05:43:31 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.