Bug 867254 - pacemaker 1.1.8 is FTBFS on ARM
pacemaker 1.1.8 is FTBFS on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pacemaker (Show other bugs)
18
arm7 Linux
high Severity urgent
: ---
: ---
Assigned To: Andrew Beekhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-10-17 03:07 EDT by Peter Robinson
Modified: 2012-11-13 06:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 06:36:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-10-17 03:07:08 EDT
pacemaker has regressed on ARM since 1.1.7 which built fine. 

koji failure: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1203947

problem output:

ipc.c: In function 'crm_ipc_read':
ipc.c:458:49: error: cast increases required alignment of target type [-Werror=cast-align]
ipc.c: In function 'internal_ipc_get_reply':
ipc.c:523:50: error: cast increases required alignment of target type [-Werror=cast-align]
ipc.c: In function 'crm_ipc_send':
ipc.c:627:46: error: cast increases required alignment of target type [-Werror=cast-align]
cc1: all warnings being treated as errors
gmake[2]: *** [ipc.lo] Error 1
gmake[2]: *** Waiting for unfinished jobs....
Comment 1 Fedora Update System 2012-10-17 11:29:33 EDT
pacemaker-1.1.8-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pacemaker-1.1.8-3.fc18
Comment 2 Fedora Update System 2012-10-17 13:35:34 EDT
Package pacemaker-1.1.8-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pacemaker-1.1.8-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16322/pacemaker-1.1.8-3.fc18
then log in and leave karma (feedback).
Comment 3 Peter Robinson 2012-11-13 06:36:51 EST
Closing as fixed and update is stable

Note You need to log in before you can comment on or make changes to this bug.