This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 867296 - NameError: global name 'gtk_call_once' is not defined
NameError: global name 'gtk_call_once' is not defined
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
abrt_hash:1fa678de4db881b2d8b3e5982be...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Betappc
  Show dependency treegraph
 
Reported: 2012-10-17 05:04 EDT by Dan Mashal
Modified: 2012-10-23 08:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 08:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: anaconda-tb (163.82 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: product (6 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: type (9 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: environ (764 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: storage.log (45.91 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: version (2 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: program.log (24.56 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: anaconda.log (3.17 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: syslog (61.08 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: cmdline_file (87 bytes, text/plain)
2012-10-17 05:04 EDT, Dan Mashal
no flags Details
File: release (24 bytes, text/plain)
2012-10-17 05:05 EDT, Dan Mashal
no flags Details

  None (edit)
Description Dan Mashal 2012-10-17 05:04:32 EDT
Version-Release number of selected component:
anaconda-18.17

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.17 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 653, in _initialize
:    gtk_call_once(self._autodetectBox.set_no_show_all, False)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:NameError: global name 'gtk_call_once' is not defined
Comment 1 Dan Mashal 2012-10-17 05:04:35 EDT
Created attachment 628602 [details]
File: ifcfg.log
Comment 2 Dan Mashal 2012-10-17 05:04:38 EDT
Created attachment 628603 [details]
File: anaconda-tb
Comment 3 Dan Mashal 2012-10-17 05:04:40 EDT
Created attachment 628604 [details]
File: product
Comment 4 Dan Mashal 2012-10-17 05:04:41 EDT
Created attachment 628605 [details]
File: type
Comment 5 Dan Mashal 2012-10-17 05:04:43 EDT
Created attachment 628606 [details]
File: environ
Comment 6 Dan Mashal 2012-10-17 05:04:45 EDT
Created attachment 628607 [details]
File: storage.log
Comment 7 Dan Mashal 2012-10-17 05:04:47 EDT
Created attachment 628608 [details]
File: version
Comment 8 Dan Mashal 2012-10-17 05:04:50 EDT
Created attachment 628609 [details]
File: program.log
Comment 9 Dan Mashal 2012-10-17 05:04:53 EDT
Created attachment 628610 [details]
File: anaconda.log
Comment 10 Dan Mashal 2012-10-17 05:04:54 EDT
Created attachment 628611 [details]
File: syslog
Comment 11 Dan Mashal 2012-10-17 05:04:56 EDT
Created attachment 628612 [details]
File: hashmarkername
Comment 12 Dan Mashal 2012-10-17 05:04:57 EDT
Created attachment 628613 [details]
File: packaging.log
Comment 13 Dan Mashal 2012-10-17 05:04:59 EDT
Created attachment 628614 [details]
File: cmdline_file
Comment 14 Dan Mashal 2012-10-17 05:05:01 EDT
Created attachment 628615 [details]
File: release
Comment 15 Martin Sivák 2012-10-17 05:16:02 EDT
Oops.. Will be fixed with the new build.
Comment 16 Adam Williamson 2012-10-17 13:44:16 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . We agreed that as there's no information on how to trigger this crash, it's impossible to determine whether it's a blocker or not. The determination is delayed, and there was solid consensus that Dan should be roundly flogged for nominating a blocker with no explanation :)

Dan (or Martin), please explain what causes this crash so we can determine the blocker status.
Comment 17 Adam Williamson 2012-10-17 14:27:44 EDT
Dan says he thinks this could be caused by the dependency issue between PulseAudio and webrtc - note that this dependency error shows up in the packaging.log attached to the bug.
Comment 18 Mark Hamzy 2012-10-17 15:35:42 EDT
I see this on ppc64 after selecting the language and before doing anything else.
Comment 19 Fedora Update System 2012-10-17 22:36:16 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 20 Fedora Update System 2012-10-18 11:28:07 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-10-19 21:32:07 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 22 Fedora Update System 2012-10-19 23:50:49 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 23 Martin Sivák 2012-10-23 05:49:48 EDT
Adam:

this was caused by missing import in anaconda sources. gtk_call_once is our helper method (pyanaconda/ui/gui/utils.py), part of the threading fix patchset.
Comment 24 Kamil Páral 2012-10-23 08:54:41 EDT
Dan claims VERIFIED and anaconda is stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.