Bug 867335 - engine: there is no event sent to event log for cancel migration
engine: there is no event sent to event log for cancel migration
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Arik
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 06:40 EDT by Dafna Ron
Modified: 2012-11-19 07:01 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 07:01:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (72.52 KB, image/jpeg)
2012-10-17 06:40 EDT, Dafna Ron
no flags Details
logs (212.00 KB, application/x-gzip)
2012-10-17 06:44 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-17 06:40:49 EDT
Created attachment 628664 [details]
screen shot

Description of problem:

when we press cancel migration on a vm, there is no even shown in the event log. 
only end action status is shown in event log. 
this means that the user has no idea what is the status of the action until we get a return for command. 

Version-Release number of selected component (if applicable):

si20

How reproducible:

100%

Steps to Reproduce:
1. in a two hosts cluster with NFS storage migrate a vm
2. cancel the migration
3.

please note that if we block connectivity to storage from source vds we can see it more clearly since we see nothing for a long time and than get the error on the failure of cancel migration. 

Actual results:

we get the end result of the migration but not the event on starting the migration

Expected results:

we should get even for start of action and end of action. 

Additional info: screen shot attached. 

here you can see that only the "success" of the cancel migration is reported: 

	
2012-Oct-17, 12:07:09 Starting migration of VM RHEL-NFS-2 from Host gold-vdsc to Host gold-vdsd (User: admin@internal.).
	
2012-Oct-17, 12:07:08 Migration failed due to Error: Fatal error during migration (VM: RHEL-NFS-2, Source Host: gold-vdsc). Trying to migrate to another Host.
	
2012-Oct-17, 12:07:07 Migration cancelled for VM: RHEL-NFS-2

when my source vds was blocked to storage I could only see the failed cancel: 
	
2012-Oct-17, 12:01:06 Failed to cancel migration for VM: RHEL-NFS-9
Comment 1 Dafna Ron 2012-10-17 06:44:21 EDT
Created attachment 628665 [details]
logs
Comment 3 Arik 2012-11-19 07:01:46 EST
There is no such event for synchronous actions by design, as the results for those actions should appear quickly.

If there is a scenario in which it takes a long time to get the result for such action, it should be declared as a different bug

Note You need to log in before you can comment on or make changes to this bug.