Bug 867339 - [RFE] Missing operations for snapshots in RESTAPI
[RFE] Missing operations for snapshots in RESTAPI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.4.0
Assigned To: Maor
Gadi Ickowicz
storage
: AutomationBlocker, FutureFeature, Improvement
Depends On:
Blocks: rhev3.4snap1
  Show dependency treegraph
 
Reported: 2012-10-17 06:53 EDT by Petr Dufek
Modified: 2016-02-10 15:22 EST (History)
17 users (show)

See Also:
Fixed In Version: av4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 10:03:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11163 None None None Never
oVirt gerrit 21282 None None None Never
oVirt gerrit 25688 None None None Never
oVirt gerrit 25689 None None None Never
oVirt gerrit 25690 None None None Never
oVirt gerrit 25691 None None None Never

  None (edit)
Description Petr Dufek 2012-10-17 06:53:17 EDT
Description of problem:
In RESTAPI some opertions for snapshot are missing:
 - preview
 - commit
 - undo 

Those operations are available in webadmin, but via RESTAPI there's only 'restore' opearation available.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-20.el6ev.noarch
Comment 2 Ravi Nori 2013-01-17 13:18:55 EST
link : http://gerrit.ovirt.org/#/c/11163/

change id : If2bbf6ba2c3f71230d3fdd98ca60c0c3d0f902fb
Comment 3 Jakub Libosvar 2013-07-08 11:13:54 EDT
Verified rhevm-3.3.0-0.5.master.el6ev.noarch
Comment 4 Michael Pasternak 2013-11-04 03:44:02 EST
reverted due to engine inability to provide infrastructure that works for restapi,
(please revert original commit [1])

[1] http://gerrit.ovirt.org/#/c/11163/
Comment 5 Michael Pasternak 2013-11-04 03:44:54 EST
*** Bug 1018554 has been marked as a duplicate of this bug. ***
Comment 8 Charlie 2013-11-27 19:08:06 EST
This bug is currently attached to errata RHEA-2013:15231. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 13 Gadi Ickowicz 2014-03-30 06:57:57 EDT
Verified on is4.

preview, commit and undo work as expected:

POST /api/{vm:id}/{preview|commit|undo}_snapshot
BODY:
<action>
</action>

for preview body requires <action><snapshot id="{snapshot:id}"></snapshot></action>
Comment 14 Gadi Ickowicz 2014-03-30 08:17:27 EDT
Not verified on is4 as per comment 13, verified on AV4.
Comment 15 Itamar Heim 2014-06-12 10:03:27 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.