Bug 867368 - Review Request: canl-c - Common Authentication Library for C
Review Request: canl-c - Common Authentication Library for C
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mattias Ellert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:36 EDT by František Dvořák
Modified: 2013-10-10 14:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 14:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mattias.ellert: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description František Dvořák 2012-10-17 07:36:17 EDT
Spec URL: http://scientific.zcu.cz/fedora/canl-c-2.0.0-1/canl-c.spec
SRPM URL: http://scientific.zcu.cz/fedora/canl-c-2.0.0-1/canl-c-2.0.0-1.fc19.src.rpm
Description: This is the C part of the EMI caNl -- the Common Authentication Library.
Fedora Account System Username: valtri

Additional notes:
- I'm upstream maintainer
- I don't have a sponsor yet
- koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4598795
Comment 1 Susi Lehtola 2012-10-17 08:41:44 EDT
Well, the project URL
Url:            http://glite.cern.ch

is obviously incorrect, since there's no mention of EMI on the page.
Comment 2 František Dvořák 2012-10-17 09:03:58 EDT
Right, URL http://www.eu-emi.eu will be better.

EMI project covers several middlewares (including gLite), but canl-c is a product of EMI project.
Comment 3 František Dvořák 2012-11-18 16:01:53 EST
Spec URL: http://scientific.zcu.cz/fedora/canl-c-2.0.2-1/canl-c.spec
SRPM URL: http://scientific.zcu.cz/fedora/canl-c-2.0.2-1/canl-c-2.0.2-1.fc19.src.rpm
Koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4701544

This is a new version of canl-c - added missing licence file. In packaging fixed the URL, and API documentation moved into canl-c-devel.
Comment 4 František Dvořák 2012-12-05 06:21:48 EST
Rex Dieter was willing to sponsor me, removing the FE-NEEDSPONSOR block.
Comment 6 Mattias Ellert 2013-01-15 10:53:27 EST
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated

Comment:

There is inconsistent capitalization in summaries and descriptions. Both
caNl and caNL is used. I think the intention was to use caNl everywhere.

===== MUST items =====

C/C++:
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.0
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[!]: %build honors applicable compiler flags or justifies otherwise.
     %{optflags} and %{default_ldflags} not passed to gcc
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[!]: Fully versioned dependency in subpackages, if present.
     -devel has, -examples has not
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
[x]: License file installed when any subpackage combination is installed.
[!]: Package consistently uses macros (instead of hard-coded directory
     names).
     --prefix=%{_prefix} would be better than --prefix=/usr
     %{_defaultdocdir} would be better than /usr/share/doc
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see below).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Useful -debuginfo package or justification otherwise.
[-]: Large documentation must go in a -doc subpackage.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: canl-c-debuginfo-2.0.3-1.fc17.x86_64.rpm
          canl-c-2.0.3-1.fc17.x86_64.rpm
          canl-c-examples-2.0.3-1.fc17.x86_64.rpm
          canl-c-devel-2.0.3-1.fc17.x86_64.rpm
          canl-c-2.0.3-1.fc17.src.rpm
canl-c.x86_64: W: shared-lib-calls-exit /usr/lib64/libcanl_c.so.2.0.3 exit@GLIBC_2.2.5
canl-c-examples.x86_64: W: no-documentation
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-server
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-proxy-init
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-client
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-delegation
5 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint canl-c canl-c-devel canl-c-debuginfo canl-c-examples
canl-c.x86_64: W: shared-lib-calls-exit /usr/lib64/libcanl_c.so.2.0.3 exit@GLIBC_2.2.5
canl-c-examples.x86_64: W: no-documentation
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-server
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-proxy-init
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-client
canl-c-examples.x86_64: W: no-manual-page-for-binary emi-canl-delegation
4 packages and 0 specfiles checked; 0 errors, 6 warnings.
# echo 'rpmlint-done:'



Requires
--------
canl-c-debuginfo-2.0.3-1.fc17.x86_64.rpm (rpmlib, GLIBC filtered):
    

canl-c-2.0.3-1.fc17.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /sbin/ldconfig  
    libc.so.6()(64bit)  
    libcares.so.2()(64bit)  
    libssl.so.10()(64bit)  
    rtld(GNU_HASH)  

canl-c-examples-2.0.3-1.fc17.x86_64.rpm (rpmlib, GLIBC filtered):
    
    libc.so.6()(64bit)  
    libcanl_c.so.2()(64bit)  
    libcares.so.2()(64bit)  
    libcrypto.so.10()(64bit)  
    libssl.so.10()(64bit)  
    rtld(GNU_HASH)  

canl-c-devel-2.0.3-1.fc17.x86_64.rpm (rpmlib, GLIBC filtered):
    
    canl-c(x86-64) = 2.0.3-1.fc17
    krb5-devel(x86-64)  
    libcanl_c.so.2()(64bit)  



Provides
--------
canl-c-debuginfo-2.0.3-1.fc17.x86_64.rpm:
    
    canl-c-debuginfo = 2.0.3-1.fc17
    canl-c-debuginfo(x86-64) = 2.0.3-1.fc17

canl-c-2.0.3-1.fc17.x86_64.rpm:
    
    canl-c = 2.0.3-1.fc17
    canl-c(x86-64) = 2.0.3-1.fc17
    libcanl_c.so.2()(64bit)  

canl-c-examples-2.0.3-1.fc17.x86_64.rpm:
    
    canl-c-examples = 2.0.3-1.fc17
    canl-c-examples(x86-64) = 2.0.3-1.fc17

canl-c-devel-2.0.3-1.fc17.x86_64.rpm:
    
    canl-c-devel = 2.0.3-1.fc17
    canl-c-devel(x86-64) = 2.0.3-1.fc17



MD5-sum check
-------------
http://scientific.zcu.cz/emi/emi.canl.c/canl-c-2.0.3.tar.gz :
  CHECKSUM(SHA256) this package     : 087401327bfd4dad7ec9a727571fd97d1c5e5e373f60c7b834af46325790f7f3
  CHECKSUM(SHA256) upstream package : 087401327bfd4dad7ec9a727571fd97d1c5e5e373f60c7b834af46325790f7f3


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-17-x86_64
Command line :/usr/bin/fedora-review -n canl-c
Comment 7 František Dvořák 2013-01-17 04:48:09 EST
Spec URL: http://scientific.zcu.cz/fedora/canl-c-2.0.3-1b/canl-c.spec
SRPM URL: http://scientific.zcu.cz/fedora/canl-c-2.0.3-1b/canl-c-2.0.3-1.fc19.src.rpm
Koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4877232

Thanks for the review. This is the updated package, for the LDFLAGS I used "%{?__global_ldflags}".
Comment 8 Mattias Ellert 2013-01-21 07:09:23 EST
Package approved.
Comment 9 František Dvořák 2013-01-21 11:37:31 EST
New Package SCM Request
=======================
Package Name: canl-c
Short Description: Common Authentication Library for C
Owners: valtri
Branches: f18 e6
InitialCC:
Comment 10 František Dvořák 2013-01-21 23:20:58 EST
New Package SCM Request
=======================
Package Name: canl-c
Short Description: Common Authentication Library for C
Owners: valtri
Branches: f18 el6
InitialCC:
Comment 11 Jon Ciesla 2013-01-22 08:59:37 EST
Git done (by process-git-requests).
Comment 12 Fedora Update System 2013-01-22 14:23:00 EST
canl-c-2.0.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/canl-c-2.0.3-1.fc18
Comment 13 Fedora Update System 2013-01-22 15:41:40 EST
canl-c-2.0.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/canl-c-2.0.3-1.el6
Comment 14 Fedora Update System 2013-01-23 11:25:59 EST
canl-c-2.0.3-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 15 František Dvořák 2013-01-31 16:54:02 EST
There are some important fixes in upstream, plus minor issue - pdf file in devel subpackage differs between builds (i686 vs x86_64) - moved to doc subpackage.

The new first package to release instead:

Spec URL: http://scientific.zcu.cz/fedora/canl-c-2.0.7-1/canl-c.spec
SRPM URL: http://scientific.zcu.cz/fedora/canl-c-2.0.7-1/canl-c-2.0.7-1.fc19.src.rpm
Comment 16 Fedora Update System 2013-01-31 17:23:35 EST
canl-c-2.0.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/canl-c-2.0.7-1.fc18
Comment 17 Fedora Update System 2013-01-31 17:47:04 EST
canl-c-2.0.7-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/canl-c-2.0.7-1.el6
Comment 18 Fedora Update System 2013-02-26 14:17:13 EST
canl-c-2.0.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 19 Fedora Update System 2013-02-26 21:37:48 EST
canl-c-2.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.
Comment 20 František Dvořák 2013-09-24 07:03:31 EDT
Package Change Request
======================
Package Name: canl-c
New Branches: el5
Owners: valtri

canl-c is dependency for new version of gridsite, which is in EPEL 5. Thank you.
Comment 21 Jon Ciesla 2013-09-24 08:18:03 EDT
Git done (by process-git-requests).
Comment 22 Fedora Update System 2013-09-24 15:09:17 EDT
canl-c-2.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/canl-c-2.1.2-1.el5
Comment 23 Fedora Update System 2013-10-10 14:33:49 EDT
canl-c-2.1.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.

Note You need to log in before you can comment on or make changes to this bug.