Bug 867387 - Port mirroring is not working on RHEVH as some modules are missing
Port mirroring is not working on RHEVH as some modules are missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
GenadiC
network
: TestBlocker, ZStream
Depends On:
Blocks: 867466
  Show dependency treegraph
 
Reported: 2012-10-17 08:16 EDT by GenadiC
Modified: 2013-02-28 11:40 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Enabling port mirroring on Red Hat Enterprise Virtualization Hypervisor failed with a fatal modprobe error caused by modules which were missing from the build. This is caused by the build server environment preventing inclusion of the sch_ingress.ko kernel module. This fix instructs the kernel to keep the sch_ingress.ko kernel module available, thereby allowing the module to be loaded and port mirroring to be enabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:40:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages with the error message (963.22 KB, application/octet-stream)
2012-10-17 08:16 EDT, GenadiC
no flags Details

  None (edit)
Description GenadiC 2012-10-17 08:16:46 EDT
Created attachment 628742 [details]
/var/log/messages with the error message

Description of problem:
It's impossible to enable port mirroring on RHEVH as some modules are missing
I get the following in /var/log/messages: modprobe: FATAL: Could not open '/lib/modules/2.6.32-279.9.1.el6.x86_64/kernel/net/sched/sch_ingress.ko': No such file or directory


How reproducible:
Always

Steps to Reproduce:
1. Try to enable port mirroring on one of the networks of the VM

Actual results:
Error message

Expected results:
Port mirroring should work on RHEVH

Additional info:
Comment 2 Mike Burns 2012-10-17 08:41:54 EDT
Upstream Patch:  http://gerrit.ovirt.org/8631
Comment 7 GenadiC 2012-11-12 06:56:50 EST
Verified in SI24.1 - release 6.3 (20121107.0.auto133)
Comment 9 errata-xmlrpc 2013-02-28 11:40:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.