Bug 867396 - Review Request: yubikey-personalization-gui - A gui tool to personalize yubikeys
Review Request: yubikey-personalization-gui - A gui tool to personalize yubikeys
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 08:40 EDT by Maxim Burgerhout
Modified: 2012-10-31 10:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 10:54:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
volker27: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Maxim Burgerhout 2012-10-17 08:40:45 EDT
Spec URL: http://fedorapeople.org/~wzzrd/yubikey-personalization-gui/yubikey-personalization-gui.spec
SRPM URL: http://fedorapeople.org/~wzzrd/yubikey-personalization-gui/yubikey-personalization-gui-3.1.1-1.fc18.src.rpm
Description: Yubico's YubiKey can be re-programmed with a new AES key. This is a graphical tool that makes this an easy task.

Fedora Account System Username: wzzrd

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4598914
Comment 1 Volker Fröhlich 2012-10-22 16:53:31 EDT
You can drop the scriplets, since you don't install icons in the hicolor dir, compare to http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Icon_Cache

Don't gzip the man page. Man pages are compressed by rpmbuild. Also make it ...%{name}.1* in the files section, as the compression algorithm might change.
Comment 3 Volker Fröhlich 2012-10-29 17:14:02 EDT
I trust in you removing the BR and therefore the package is

==APPROVED==

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[!]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
     Note: These BR are not needed: gcc-c++
See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2


===== MUST items =====

C/C++:
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[!]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
     Note: These BR are not needed: gcc-c++
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package installs a %{name}.desktop using desktop-file-install if there is
     such a file.
[-]: Development files must be in a -devel package
[-]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.

Also builds on PPC

[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[-]: Large documentation files are in a -doc subpackage, if required.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "BSD (2 clause)", "Unknown or generated". 2 files have unknown license.
     Detailed output of licensecheck in
     /media/speicher1/makerpm/rpmbuild/SPECS/867396-yubikey-personalization-
     gui/licensecheck.txt

These two files are shell scripts, that are neither used, nor shipped with the binary RPM.
They state no license.

[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[-]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[-]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Useful -debuginfo package or justification otherwise.

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: Package functions as described.

It starts and throws no visible errors. I don't own such a device, so I can't
test any further than that.

[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (yubikey-personalization-gui-3.1.1.tar.gz)
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: yubikey-personalization-gui-3.1.1-2.fc16.x86_64.rpm
          yubikey-personalization-gui-3.1.1-2.fc16.src.rpm
          yubikey-personalization-gui-debuginfo-3.1.1-2.fc16.x86_64.rpm
yubikey-personalization-gui.x86_64: W: spelling-error %description -l en_US Yubico's -> Rubicon's
yubikey-personalization-gui.src: W: spelling-error %description -l en_US Yubico's -> Rubicon's
3 packages and 0 specfiles checked; 0 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint yubikey-personalization-gui-debuginfo yubikey-personalization-gui
yubikey-personalization-gui-debuginfo.x86_64: I: enchant-dictionary-not-found en_US
2 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
yubikey-personalization-gui-3.1.1-2.fc16.x86_64.rpm (rpmlib, GLIBC filtered):
    
    libQtCore.so.4()(64bit)  
    libQtGui.so.4()(64bit)  
    libc.so.6()(64bit)  
    libgcc_s.so.1()(64bit)  
    libgcc_s.so.1(GCC_3.0)(64bit)  
    libm.so.6()(64bit)  
    libpthread.so.0()(64bit)  
    libstdc++.so.6()(64bit)  
    libstdc++.so.6(CXXABI_1.3)(64bit)  
    libykpers-1.so.1()(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.0)(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.4)(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.5)(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.6)(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.7)(64bit)  
    libykpers-1.so.1(LIBYKPERS_1.8)(64bit)  
    libyubikey.so.0()(64bit)  
    libyubikey.so.0(YUBIKEY_1.0)(64bit)  
    libyubikey.so.0(YUBIKEY_1.5)(64bit)  
    rtld(GNU_HASH)  

yubikey-personalization-gui-debuginfo-3.1.1-2.fc16.x86_64.rpm (rpmlib, GLIBC filtered):
    



Provides
--------
yubikey-personalization-gui-3.1.1-2.fc16.x86_64.rpm:
    
    yubikey-personalization-gui = 3.1.1-2.fc16
    yubikey-personalization-gui(x86-64) = 3.1.1-2.fc16

yubikey-personalization-gui-debuginfo-3.1.1-2.fc16.x86_64.rpm:
    
    yubikey-personalization-gui-debuginfo = 3.1.1-2.fc16
    yubikey-personalization-gui-debuginfo(x86-64) = 3.1.1-2.fc16



MD5-sum check
-------------
https://yubikey-personalization.googlecode.com/files/yubikey-personalization-gui-3.1.1.tar.gz :
  CHECKSUM(SHA256) this package     : b3ddf4f9942eec1169630cc12df9628caaff2a0e8e290e1a395bf91689cd838e
  CHECKSUM(SHA256) upstream package : b3ddf4f9942eec1169630cc12df9628caaff2a0e8e290e1a395bf91689cd838e


Generated by fedora-review 0.3.0 (c78e275) last change: 2012-09-24
Buildroot used: fedora-16-x86_64
Command line :/usr/bin/fedora-review -b 867396
Comment 4 Maxim Burgerhout 2012-10-30 17:02:42 EDT
Consider the BR removed. Thanks for reviewing!

New Package SCM Request
=======================
Package Name: yubikey-personalization-gui
Short Description: A gui tool to personalize yubikeys
Owners: wzzrd
Branches: f17 f18
InitialCC:
Comment 5 Gwyn Ciesla 2012-10-31 07:14:50 EDT
Git done (by process-git-requests).
Comment 6 Fedora Update System 2012-10-31 10:52:21 EDT
yubikey-personalization-gui-3.1.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yubikey-personalization-gui-3.1.1-2.fc18
Comment 7 Fedora Update System 2012-10-31 10:53:12 EDT
yubikey-personalization-gui-3.1.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yubikey-personalization-gui-3.1.1-2.fc17
Comment 8 Maxim Burgerhout 2012-10-31 10:54:18 EDT
Built and submitted as update for F17, F18 and Rawhide.

Note You need to log in before you can comment on or make changes to this bug.