Bug 867407 - Journal leaks memory
Journal leaks memory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 09:01 EDT by Zdenek Kabelac
Modified: 2012-12-20 10:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:56:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2012-10-17 09:01:16 EDT
Description of problem:

It seems the process 'systemd-journal' is eating a lot of memory on my system.
(Running lots of test, thus producing lots of logs')

The max size I've noticed so far before  restarting journal service was about 260MB -  service restart fixes the issue for me for a while.

Looking at my:   /etc/systemd/journald.conf  
it's missing  'ImportKernel=no' from .rpmnew.

Is that a reason for unlimited memory growth ?

Version-Release number of selected component (if applicable):
systemd-194-1.fc18.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Zdenek Kabelac 2012-10-17 09:19:34 EDT
Yes, looks like there is a lot of file (already invisible in system)

/run/log/journal/xxxx/system.journal

in the process map.
Comment 3 Fedora Update System 2012-10-22 21:04:51 EDT
systemd-195-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-1.fc18
Comment 4 Fedora Update System 2012-10-23 02:48:33 EDT
Package systemd-195-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-26 15:37:46 EDT
Package systemd-195-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:56:17 EST
systemd-195-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.