Bug 867435 - [RFE] Importing GPG file with some random text shouldn't be allowed
[RFE] Importing GPG file with some random text shouldn't be allowed
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 09:57 EDT by Sachin Ghai
Modified: 2017-02-09 15:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-09 15:50:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Imported key file with some random text (38.23 KB, image/png)
2012-10-17 09:57 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-10-17 09:57:43 EDT
Created attachment 628828 [details]
Imported key file with some random text

Description of problem:
I can import any random text file as GPG key file from UI. So I think UI should validate the key file first. 

Version-Release number of selected component (if applicable):
katello-configure-1.1.9-7.el6cf.noarch
katello-common-1.1.12-16.el6cf.noarch
katello-1.1.12-16.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.1.8-7.el6cf.noarch
katello-certs-tools-1.1.8-1.el6cf.noarch
katello-glue-candlepin-1.1.12-16.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.1.8-7.el6cf.noarch
katello-glue-pulp-1.1.12-16.el6cf.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.1.1-1.el6cf.noarch
katello-all-1.1.12-16.el6cf.noarch


How reproducible:
always

Steps to Reproduce:
1. Create a text file with some random text
2. Import it,  click the Content->Repositories->GPG Keys subtab
3.
  
Actual results:
UI successfully imports any file with some random text as GPG key

Expected results:
UI should validate the gpg key file before import. and Should raise an error some thing like: "Contents are not valid, Please import some valid key file."

Additional info:
Comment 3 Bryan Kearney 2016-07-08 16:46:38 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Todd Warner 2017-02-09 15:50:13 EST
Due to the age of this request, and our prioritization, I am closing this bugzilla. The prioritization ensured that it was not something we could ever address in a meaningful timeframe.

-todd warner, PM, Satellite

Note You need to log in before you can comment on or make changes to this bug.