Bug 867445 - some update overwrote /etc/nsswitch.conf and lost user's changes
some update overwrote /etc/nsswitch.conf and lost user's changes
Status: CLOSED DUPLICATE of bug 867124
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:25 EDT by John Ellson
Modified: 2016-11-24 10:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 11:05:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-10-17 10:25:11 EDT
Description of problem:
Some update overwrote /etc/nsswitch.conf and lost user's changes.

I had manually changed /etc/nsswitch.conf with:
  hosts:      files mdns4_minimal [NOTFOUND=return] dns mdns myhostname

This change was lost during some recent upgrade.   glibc is the owner of this file, and was updated at about the right time to be the cause of the problem, but I could not recreate the problem with "yum reinstall glibc"

Version-Release number of selected component (if applicable):
glibc-2.16-20.fc18.x86_64

How reproducible:
not

Steps to Reproduce:
1.unknown
2.
3.
  
Actual results:
Lost user's changes to /etc/nsswitch.conf

Expected results:
Minimally, user's changes need to be preserved in a: /etc/nsswitch.conf.rpmsave

Additional info:
Comment 1 Jeff Law 2012-10-17 11:05:57 EDT

*** This bug has been marked as a duplicate of bug 867124 ***

Note You need to log in before you can comment on or make changes to this bug.