Bug 867452 - SELinux is preventing /usr/bin/bash from using the 'dac_override' capabilities.
SELinux is preventing /usr/bin/bash from using the 'dac_override' capabilities.
Status: CLOSED DUPLICATE of bug 867449
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6afeda100b07420409e92bbd1fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:31 EDT by Alison Lemes
Modified: 2012-10-19 05:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 05:52:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-17 10:31 EDT, Alison Lemes
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-17 10:31 EDT, Alison Lemes
no flags Details

  None (edit)
Description Alison Lemes 2012-10-17 10:31:17 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.1-1.fc17.x86_64

description:
:SELinux is preventing /usr/bin/bash from using the 'dac_override' capabilities.
:
:*****  Plugin dac_override (91.4 confidence) suggests  ***********************
:
:If você deseja ajudar a identificar se o domínio precisa deste acesso ou se você possui um arquivo com as permissões erradas em seu sistema.
:Then ligue a auditoria completa para obter informações de caminho sobre ofender arquivo e gerar um erro novamente.
:Do
:
:Ligue auditoria completa
:# auditctl -w /etc/shadow -p w
:Tente recriar o AVC. Depois execute
:# ausearch -m avc -ts recent
:Caso você veja a memória PATH verifique a propriedade ou permissões no arquivo e repare-o, caso contrário reporte como um bugzilla.
:
:*****  Plugin catchall (9.59 confidence) suggests  ***************************
:
:If você acredita que o bash deva ser permitido a capacidade de dac_override  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep sh /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Objects                 [ capability ]
:Source                        sh
:Source Path                   /usr/bin/bash
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           bash-4.2.37-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-153.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc17.x86_64 #1 SMP Wed Oct
:                              10 12:13:05 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-17 11:28:12 BRT
:Last Seen                     2012-10-17 11:28:12 BRT
:Local ID                      0ea75803-1359-4b23-ba0c-55dfcc587242
:
:Raw Audit Messages
:type=AVC msg=audit(1350484092.69:116): avc:  denied  { dac_override } for  pid=4545 comm="sh" capability=1  scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=AVC msg=audit(1350484092.69:116): avc:  denied  { open } for  pid=4545 comm="sh" path="/dev/pts/3" dev="devpts" ino=6 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_devpts_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1350484092.69:116): arch=x86_64 syscall=open success=yes exit=EIO a0=19ad010 a1=802 a2=7fff66621e00 a3=1000 items=0 ppid=4541 pid=4545 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm=sh exe=/usr/bin/bash subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: sh,mozilla_plugin_t,mozilla_plugin_t,capability,dac_override
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t self:capability dac_override;
:allow mozilla_plugin_t user_devpts_t:chr_file open;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t self:capability dac_override;
:allow mozilla_plugin_t user_devpts_t:chr_file open;
:
Comment 1 Alison Lemes 2012-10-17 10:31:23 EDT
Created attachment 628852 [details]
File: type
Comment 2 Alison Lemes 2012-10-17 10:31:25 EDT
Created attachment 628853 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-19 05:52:00 EDT

*** This bug has been marked as a duplicate of bug 867449 ***

Note You need to log in before you can comment on or make changes to this bug.