Bug 867461 - Gedit opens up with changes already marked for saving when run by KDE
Gedit opens up with changes already marked for saving when run by KDE
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:47 EDT by Vitezslav Humpa
Modified: 2014-01-28 11:47 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 11:47:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-10-17 10:47:56 EDT
Description of problem:
When running gedit under KDE, the empty default document is already tagged with * as if some changes were already done on startup. The '*Unsaved Document 1' is empty and keeps open when some other file is open. Choosing other themes than oxygen like the original 'adwaita' has no impact on this behavior. This only happens if running gedit using kickoff, krunner or other KDE means - not from the terminal.

Version-Release number of selected component (if applicable):
gedit-3.6.0-1.el7.x86_64 (gedit-3.6.1-1.fc18.x86_64 as well)

How reproducible:
Always

Steps to Reproduce:
1. Log in KDE
2. Run Gedit using krunner or kickoff, or open file with it
  
Actual results:
'*Unsaved Document 1' marked with changes already

Additional info:
Not sure whether this is fault of gedit itself, gtksourceview3 or some KDE component. Running KDE with other wm than kwin (metacity) makes no difference too. Since the problem only happens while running using KDE's own means, I chose to report against kde-workspace.
Comment 1 Ray Strode [halfline] 2014-01-28 11:20:33 EST
realistically, compared to other pending issues, this one probably won't ever get high enough on the priority queue to investigate and fix without customer interest.  devnak
Comment 2 RHEL Product and Program Management 2014-01-28 11:47:07 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.