Bug 867469 - f18b tc4 anaconda (graphical) there is no option to not to install a boot loader
f18b tc4 anaconda (graphical) there is no option to not to install a boot loader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 11:09 EDT by Reartes Guillermo
Modified: 2013-03-12 10:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 10:40:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of proposal #1 for 'do not install bootloader' (76.77 KB, image/png)
2012-10-17 11:10 EDT, Reartes Guillermo
no flags Details
screenshot of proposal #2 for 'do not install bootloader' (60.42 KB, image/png)
2012-10-17 11:10 EDT, Reartes Guillermo
no flags Details
anaconda.log (smoke3) (11.20 KB, text/plain)
2012-12-05 15:36 EST, Reartes Guillermo
no flags Details
storage.log (smoke3) (108.44 KB, text/plain)
2012-12-05 15:36 EST, Reartes Guillermo
no flags Details
program.log (smoke3) (52.13 KB, text/plain)
2012-12-05 15:37 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-17 11:09:39 EDT
Description of problem:

I was not able to find where to specify that i do not want to install any boot-loader. In some cases, an user might want to install Fedora as a secondary
os (or there might be multiple os on the machine). In that case, such user might
want to use Anaconda (Fedora 18's payload delivery method) to put the F18 Payload on a partition. Anaconda will not be able to handle all possibilities, but it also should not impede such setups.

Version-Release number of selected component (if applicable):
F18b TC4

How reproducible:
always
i did not test text mode for this.
 
Actual results:
it appears as one should always install a bootloader, thus might create issues
for people who have complex setups with multiple os.

Expected results:
be able to just use anaconda to put F18 payload to a partition.

Additional info:
This feature was present in previous Fedora versions.
Comment 1 Reartes Guillermo 2012-10-17 11:10:21 EDT
Created attachment 628877 [details]
screenshot of proposal #1 for 'do not install bootloader'
Comment 2 Reartes Guillermo 2012-10-17 11:10:57 EDT
Created attachment 628878 [details]
screenshot of proposal #2 for 'do not install bootloader'
Comment 3 Chris Lumens 2012-10-17 19:49:34 EDT
Perhaps a simpler modification that involves the current design would be to just allow you to deselect whatever device is selected on the shopping cart dialog?
Comment 4 Reartes Guillermo 2012-10-17 19:55:24 EDT
Whatever works, comment #3 seems ok.
Being able to deselect devices sounds reasonable to me.

If that cannot be done, anaconda should at least provide a boot parameter.
Comment 5 Reartes Guillermo 2012-10-23 17:32:34 EDT
F18b TC6 still does not permit to not install a boot loader.

The deadline for "Features 100% Complete" is today. 

Please consider adding that feature since there will be configuration in which you would not want anaconda to touch the boot sector. (or update the deadline date in F18 schedule).
Comment 6 Chris Lumens 2012-10-23 17:33:53 EDT
Feature completion does not mean bug free.  Otherwise, the final release would be at the same time.
Comment 7 Reartes Guillermo 2012-11-30 16:28:57 EST
Any news regarding the option to not to install any boot-loader?
Comment 8 Chris Lumens 2012-11-30 16:33:47 EST
It's not as discoverable as I would like, but basically you can go into the disk shopping cart, highlight whatever disk has the bootloader check, click the button, and it'll unset that device for receiving the bootloader.  Thus, you should not get a bootloader installed.

I could probably change the button text, but we are after string freeze.
Comment 9 Chris Lumens 2012-11-30 16:53:17 EST
Might commit http://fpaste.org/3y3m/ to change up the button text anyway.  It would be a string that likely wouldn't get translated, but that's not such a big deal.  More important to not break existing strings.
Comment 10 Paul Franklin (RHlists) 2012-12-05 13:02:31 EST
I only have an i386 machine so I'm unable to use the "smoke"
builds (as they are only for 64-bit machines), so I am stuck
using F18Beta (and thus anaconda 18.29.2) until the first
"final TC" comes along.  So I wonder if I can ask for an
updates.img patch for this fix (against 18.29.2 I mean)?

Thanks.
Comment 11 Reartes Guillermo 2012-12-05 15:36:11 EST
Created attachment 658366 [details]
anaconda.log (smoke3)

@Chris Lumens

Thanks for your previous prompt response, i could not test it until today.

I downloaded smoke3 netinstall (too slow connection and no deltaisos makes
downloading the whole iso not possible, also i can only install the minimal
package set for the same reason).

From the UI perspective, it looks clear and understandable. 

Performed steps:

0. Restore the working w7 qemu image and test that it boots: it does.
1. Boot F18b (anaconda smoke3) netinstall and use closest mirror.
2. Selected 'minimal' package set.
3. Select the disk containing W7 (in this case, there is only one disk).
4. Set anaconda's option to NOT to install any bootloader.
5. Selected automatic partitioning, default type (lvm).
6. Reclaim space: set to 'shrink' the big ntfs partition.
7. Installed F18b smoke3 ok, but...
8. After reboot, it becomes clear that anaconda did not honor the 
'do not install bootloader' directive for some reason.

9. Goto Step #0 and retry once more. Same result again.

Note: I performed the steps above to test this bug-report and also 875484.
I tried to install without bootloader to see if this made a difference on 875484.

I will test with another guests later and provide more feedback later.
Comment 12 Reartes Guillermo 2012-12-05 15:36:40 EST
Created attachment 658367 [details]
storage.log (smoke3)
Comment 13 Reartes Guillermo 2012-12-05 15:37:11 EST
Created attachment 658368 [details]
program.log (smoke3)
Comment 14 Reartes Guillermo 2012-12-15 17:55:49 EST
There is a 'do not install bootloader' option in anaconda.

Maybe this bug-report can be closed since it was about the lack of such option. If i find issues with that option i will file a proper bug-report for it.

Cheers.
Comment 15 Pavel Holica 2012-12-18 07:31:45 EST
Well, changing text in button and having only one is really bad, which means one button should have always same function.
Please use other technique for setting boot disk, like checkbox, radio-button or whatever, just don't use this solution.

Moving back to assigned.
Comment 16 Chris Lumens 2012-12-18 10:40:06 EST
Please don't reopen the bug just because you don't like the button.  I've talked this over with other people here and we all think it's fine, and other people on this bug report think it's fine (see comment 11).
Comment 17 Steve Tyler 2012-12-18 11:40:36 EST
(In reply to comment #15)
> Well, changing text in button and having only one is really bad, which means
> one button should have always same function.
> Please use other technique for setting boot disk, like checkbox,
> radio-button or whatever, just don't use this solution.
> 
> Moving back to assigned.

I completely agree. Having one button do two things is very confusing. As you note, there are well-established GUI elements for this exact situation.

Unfortunately, user-interface design bugs are not recognized by anaconda developers.
Comment 18 Chris Lumens 2012-12-18 11:50:52 EST
> I completely agree. Having one button do two things is very confusing. As
> you note, there are well-established GUI elements for this exact situation.

Multiple people have gone over this and said it's fine to do it this way.  The button simply toggles whether a device gets the bootloader or not.  It doesn't do two things.  It's really not complicated.

> Unfortunately, user-interface design bugs are not recognized by anaconda
> developers.

This increasingly developer-hostile attitude only serves to ensure that we ignore large parts of bug reports.  It's also completely unnecessary hyperbole.  We've got plenty of UI-related bugs that we are working on, and plenty that have been reported that we've not gotten to yet but will.  So really all the above statement does is just inflame the situation, not do anything to improve the quality or experience at all.  Please reconsider disparaging the only people who have the ability to work on your bugs.
Comment 19 Steve Tyler 2012-12-18 12:03:25 EST
Apple knows something about user-interface design:

'Do not use a push button to indicate a state, such as on or off. Instead, you can use checkboxes to indicate state, as described in “Checkbox.”'

OS X Human Interface Guidelines
UI Element Guidelines: Controls
https://developer.apple.com/library/mac/#documentation/UserExperience/Conceptual/AppleHIGuidelines/Controls/Controls.html#//apple_ref/doc/uid/TP30000359-TP6
Comment 20 Martin Banas 2012-12-18 12:04:47 EST
Btw, in comment 11 Reartes stated that this option is present, but didn't work.. I didn't find any bug from him about bootloader after that, so at least this should be properly retested


Reartes,
could you please verify that the option for not to installing bootloader works for you?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.