Bug 867503 - Munin uses perl -T, but doesn't require the perl-Taint-Runtime package
Munin uses perl -T, but doesn't require the perl-Taint-Runtime package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: munin (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 11:50 EDT by Michael
Modified: 2012-11-28 00:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 00:06:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2012-10-17 11:50:03 EDT
Description of problem:

I just updated to munin-2.0.7-1 on Fedora 17 x86_64 and began receiving emails like:

Cron <munin@deathstar> test -x /usr/bin/munin-cron && /usr/bin/munin-cron

/usr/bin/env: perl -T: No such file or directory


Version-Release number of selected component (if applicable):
munin-2.0.7-1

How reproducible:  Everytime

Steps to Reproduce:
1.  Install munin-node
2.  Do not have perl-Taint-Runtime installed
3.  Start munin
  
Actual results:


Expected results:


Additional info:

The munin rpms should have a dependency on perl-Taint-Runtime to ensure it is installed
Comment 1 Lonni J Friedman 2012-10-17 17:03:02 EDT
dupe of Bug 867437?
Comment 2 Michael 2012-10-17 17:38:43 EDT
They could be combined into a single ticket.  I searched prior to submitting, but didn't find anything on this.  

There are two issues.  One, passing additional arguments to perl via env and the second is making sure perl-Taint-Runtime is installed.  

I don't believe issue 867437 would directly address the second issue.
Comment 3 Lonni J Friedman 2012-10-17 17:47:19 EDT
Installing perl-Taint-Runtime doesn't seem to fix the cronjob errors though.
Comment 4 Michael 2012-10-17 17:48:50 EDT
It fixed it for me.  Make sure you completely stop and restart munin.

Can you now run perl -T without it complaining about uknown options?
Comment 5 Lonni J Friedman 2012-10-17 17:51:45 EDT
I thought munin (not munin-node) was cron driven?  Regardless, its a cronjob that is failing, so I'm not sure what I'd restart.  

Specifically what did you stop & restart?
Comment 6 Andras Kemeny 2012-10-19 06:03:25 EDT
confirming error. it resulted in my munin installation actually working, but not producing any images (and munin-graph.log was empty), and my root inbox filled quickly with mail describing the error above.

for now, i've fixed it using a patch found for pipermail: http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-January/029373.html

i.e. removed the -T argument from munin-graph's first line, and it works without a glitch.

but the env+perl args issue hints at something bigger and possibly much more problematic. i guess that's an issue that should be resolved ASAP.
Comment 7 Andras Kemeny 2012-10-19 15:33:07 EDT
be advised: bind9 plugin dies similarly; env and the -w switch don't play well together. remind me again, why are we using the env now?
Comment 8 Lonni J Friedman 2012-10-19 15:52:18 EDT
In one of the other numerous munin buzilla bugs associated with the 2.0.7 update, someone commented that Fedora is basically just repackaging what comes from upstream, and not making any functional changes (or enhancements).  If that's true, then this came from upstream.  No clue why the change was made though.
Comment 9 d. johnson 2012-10-19 19:00:30 EDT
Andras, because the upstream tarball has it ..  The new packages will not.

Lonni, correct. It came from upstream.

koji has a 2.0.7-2 build if you want, or 2.0.7-3 will be coming out shortly with this and a few other minor fixes.  The -3 release will be in -testing first.  Please feel free to check there and report.
Comment 10 Lonni J Friedman 2012-10-19 19:02:53 EDT
Can you post the URL(s) for the 2.0.7-3 koji builds (once available)?  I'll be happy to test them out.
Comment 11 Fedora Update System 2012-10-19 23:34:34 EDT
munin-2.0.7-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.7-3.fc16
Comment 12 Fedora Update System 2012-10-19 23:35:27 EDT
munin-2.0.7-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.7-3.fc17
Comment 13 Fedora Update System 2012-10-19 23:36:31 EDT
munin-2.0.7-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.7-3.fc18
Comment 14 Fedora Update System 2012-10-19 23:37:31 EDT
munin-2.0.7-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.7-3.el5
Comment 15 Fedora Update System 2012-10-19 23:38:49 EDT
munin-2.0.7-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.7-3.el6
Comment 16 Fedora Update System 2012-10-20 15:48:31 EDT
Package munin-2.0.7-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing munin-2.0.7-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13237/munin-2.0.7-3.el5
then log in and leave karma (feedback).
Comment 17 Lonni J Friedman 2012-10-22 15:48:02 EDT
These 2.0.7-3 RPMs, appear to be shipping 
/var/lib/munin/state-phx2.fedoraproject.org-buildvm-33.phx2.fedoraproject.org.storable

Is that intended?
Comment 18 d. johnson 2012-10-22 16:31:14 EDT
nice catch Lonni.  will update the spec once i find why it was included.

Aside from that, the original issue:

/usr/bin/env: perl -T: No such file or directory

Has it been resolved with this update?
Comment 19 Lonni J Friedman 2012-10-22 16:33:35 EDT
Yes, the cronjob failures are no longer present.  thanks
Comment 20 Fedora Update System 2012-11-04 12:20:01 EST
munin-2.0.7-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.7-5.el6
Comment 21 Fedora Update System 2012-11-04 12:22:06 EST
munin-2.0.7-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.7-5.el5
Comment 22 Fedora Update System 2012-11-11 15:33:29 EST
munin-2.0.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.8-1.el6
Comment 23 Fedora Update System 2012-11-11 15:36:42 EST
munin-2.0.8-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.8-1.el5
Comment 24 Fedora Update System 2012-11-28 00:06:11 EST
munin-2.0.8-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2012-11-28 00:09:35 EST
munin-2.0.8-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.