Bug 867573 - Docked Laptop doesn't display login screen on attached monitor
Docked Laptop doesn't display login screen on attached monitor
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 14:42 EDT by Russell Doty
Modified: 2013-08-01 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 12:22:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2012-10-17 14:42:56 EDT
Description of problem:

Booting laptop in dock with lid closed and attached monitor does not display login screen on attached monitor.

Version-Release number of selected component (if applicable):

Kernel Linux 3.6.1-1.fc17.x86_64

How reproducible:

Every time. Behavior began in the last 2-3 days; before that it worked as expected.

Steps to Reproduce:
1. Boot laptop in dock with lid closed and external monitor attached.
2.
3.
  
Actual results:

Boot messages appear on external monitor as expected.

When boot finishes, the external monitor is showing the secondary screen. Have to open the laptop lid and login using the laptop display. After logging in, the system automatically goes to mirrored displays as desired.


Expected results:

System boots and can login on the external monitor.


Additional info:

Lenovo T500. The laptop display is being reset to minimum brightness, which makes it very difficult to login - very difficult to see the mouse cursor. Can't change screen brightness until login is completed.
Comment 1 cblaauw 2012-10-18 06:01:19 EDT
When using kernel-3.5.6-1.fc17.x86_64 login screen appears on correct display.
Comment 2 Russell Doty 2012-10-18 09:33:21 EDT
That makes sense - this problem just occurred. It looks like a change sometime between kernel-3.5.6-1.fc17.x86_64 and 3.6.1-1.fc17.x86_64.
Comment 3 cblaauw 2012-10-18 15:00:01 EDT
Here's a way to solve the problem:

1. open a terminal and do a 'cp .config/monitor.xml .config/monitor.xml.org' to save your display 
settings.

2. open the gnome-control-center, click on diplays settings and change the settimgs to mirrored mode. Do not forget to apply the settings before closing.

3. in a terminal do as root do 'cp /home/$USER/.config/monitor.xml /etc/gnome-settings-daemon/xrandr/'. $USER is to be replaced by your user account name

4. in a terminal as $USER do 'cp .config/monitor.xml.org .config/monitor.xml' to restore your original settings. $USER is to be replaced by your user account name

5. log out, reboot and test the whole thing.
Comment 4 Russell Doty 2012-10-18 15:11:49 EDT
That worked!

Was this some sort of file corruption problem?
Comment 5 cblaauw 2012-10-18 15:20:02 EDT
No corruption, rather a missing file. With the operations you created a file that explicitly told GDM what you want. If the file is not there it picks one display to show the login mask. Maybe the order of displays changed with the new kernel I did not dive further, because the monitor configuration file in etc solved the problem.
Comment 6 Matthew Saltzman 2013-06-12 04:01:26 EDT
One thing about this that is curious: When the laptop is started with the lid closed and an external monitor attached via the VGA port, but the unit is not docked, the login display appears on the external monitor as expected, even though /etc/gnome-settings-daemon/xrandr/ is empty.  On another laptop, the main screen appears on the external monitor even after logging in, even though $HOME/.config/monitors.xml doesn't exist.

Also, I'm not sure "cloned" is the right setting, because the resolution won't necessarily be correct (though I suppose it doesn't matter that much for a login screen).  Wouldn't one want the external display to be primary when the lid is closed?  That's how I currently have my (logged in) display settings in $HOME/.config/monitors.xml.
Comment 7 Fedora End Of Life 2013-07-04 01:20:59 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Matthew Saltzman 2013-07-04 03:50:30 EDT
Please update Fedora version number. This is still an issue, at least in F18.
Comment 9 Matthew Saltzman 2013-07-04 03:51:46 EDT
Please update Fedora version number. This is still an issue, at least in F18.
Comment 10 Fedora End Of Life 2013-08-01 12:22:37 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.