Bug 867626 - "Can't download or revert repomd.xml for:"
"Can't download or revert repomd.xml for:"
Status: CLOSED DUPLICATE of bug 864643
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 17:14 EDT by John Reiser
Modified: 2012-10-18 09:07 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 09:07:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2012-10-17 17:14:24 EDT
Description of problem: livecd-creator fails, and the internal error reporter crashes.


Version-Release number of selected component (if applicable):
livecd-tools-18.11-1.fc18.x86_64

How reproducible: depends on mirror system


Steps to Reproduce:
1.    setarch i686 livecd-creator --verbose \
    --config=fedora-livecd-desktop.ks \
    --fslabel=F18-LiveCD-i686 \
    --cache=/var/cache/live
2.
3.
  
Actual results:
Using title 'F18 Livecd' and product 'F18 Livecd'
/usr/lib/python2.7/site-packages/pykickstart/commands/partition.py:285: UserWarning: A partition with the mountpoint / has already been defined.
  warnings.warn(_("A partition with the mountpoint %s has already been defined.") % pd.mountpoint)
Extending sparse file /var/tmp/imgcreate-hpeb_R/tmp-ykygYv/ext3fs.img to 4294967296
Losetup add /dev/loop1 mapping to /var/tmp/imgcreate-hpeb_R/tmp-ykygYv/ext3fs.img
Formating ext4 filesystem on /dev/loop1
Tuning filesystem on /dev/loop1
Extending sparse file /var/tmp/imgcreate-hpeb_R/tmp-ykygYv/ext3fs.img to 4294967296
Mounting /dev/loop1 at /var/tmp/imgcreate-hpeb_R/install_root
Retrieving file:///root/my-repo/repodata/repomd.xml ...OK
Retrieving http://mirror.es.its.nyu.edu/fedora/linux/development/18/i386/os/repodata/repomd.xml ...OK
Unable to unmount /var/tmp/imgcreate-hpeb_R/install_root//var/cache/yum normally, using lazy unmount
lazy umount succeeded on /var/tmp/imgcreate-hpeb_R/install_root//var/cache/yum
lazy umount succeeded on /var/tmp/imgcreate-hpeb_R/install_root//var/cache/yum
Unmounting directory /var/tmp/imgcreate-hpeb_R/install_root
Losetup remove /dev/loop1
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 226, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 209, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 646, in install
    ayum.setup(yum_conf, self._instroot)
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 103, in setup
    self.doTsSetup()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 129, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 137, in _getTs
    if not remove_only and self._tsInfo.pkgSack is None:
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 131, in <lambda>
    pkgSack = property(fget=lambda self: self._getPkgSack(),
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 128, in _getPkgSack
    self._pkgSack = self._pkgSackCtor()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 76, in __call__
    return self.ayum.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1009, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 348, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 184, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 275, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1399, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1585, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1581, in _getRepoXML
    self._loadRepoXML(text=self.ui_id)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1572, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1547, in _groupLoadRepoXML
    self._commonRetrieveDataMD(mdtypes)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1443, in _commonRetrieveDataMD
    self._revertOldRepoXML()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1209, in _revertOldRepoXML
    raise Errors.RepoError, "Can't download or revert repomd.xml for:" % self.ui_id
TypeError: not all arguments converted during string formatting


Expected results: success, or at least a correctly-formatted error message.


Additional info:
Comment 1 Brian Lane 2012-10-17 19:01:53 EDT
sounds like a mirror problem.

The error message is from yum, not sure if there's anything that can be done with it.
Comment 2 Zdeněk Pavlas 2012-10-18 09:07:03 EDT

*** This bug has been marked as a duplicate of bug 864643 ***

Note You need to log in before you can comment on or make changes to this bug.