Bug 867628 - stale man pages (specifically ricci_selinux(8))
stale man pages (specifically ricci_selinux(8))
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
: ManPageChange
: 891986 (view as bug list)
Depends On:
Blocks: 853970
  Show dependency treegraph
 
Reported: 2012-10-17 17:29 EDT by Jan Pokorný
Modified: 2013-02-21 03:31 EST (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-191.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:31:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-10-17 17:29:35 EDT
I have accidentally found out that man pages included selinux-policy
do not necessarily reflect the policy itself.

$ man ricci_selinux
> [...]
> SELinux defines port types to represent TCP and UDP ports.
> 
> You can see the types associated with a port by using the following
> command:
> 
> semanage port -l
> 
> Policy  governs  the access confined processes have to these ports.
> SELinux ricci policy is very flexible allowing users to setup their
> ricci processes in as secure a method as possible.
> 
> The following port types are defined for ricci:
> 
> ricci_modcluster_port_t
> 
> Default Defined Ports:
>           tcp 8021
> [...]


This does not reflect a real state as modcluster uses port 16851 as
is also contained in the policy.

Please make the selinux-policy man pages reflect the actual policy
that is included in the same package.


$ rpm -qf /usr/share/man/man8/ricci_selinux.8.gz
selinux-policy-3.7.19-154.el6.noarch
Comment 2 Miroslav Grepl 2012-10-18 04:26:42 EDT
I need to regenerate them for RHEL6.4
Comment 5 Miroslav Grepl 2013-01-04 14:52:23 EST
*** Bug 891986 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2013-02-21 03:31:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.