Bug 867652 - empty directories /var/tmp/systemd-private-* accumulate
empty directories /var/tmp/systemd-private-* accumulate
Status: CLOSED DUPLICATE of bug 801943
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 19:49 EDT by John Reiser
Modified: 2012-10-19 05:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 05:26:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2012-10-17 19:49:00 EDT
Description of problem: Empty directories /var/tmp/systemd-private-* accumulate across "shutdown -h now".


Version-Release number of selected component (if applicable):
systemd-194-1.fc18.x86_64


How reproducible: every time


Steps to Reproduce:
1. shutdown -h now
2. boot
3. look in /var/tmp
  
Actual results: Another empty directory named /var/tmp/systemd-private-*.  For instance:
-----
# cd /var/tmp; ls -lt
drwxrwxrwt. 2 root    colord       4096 Oct 17 16:05 systemd-private-XOTrD3
drwxrwxrwt. 2 root    root         4096 Oct 17 16:05 systemd-private-baSL7o
drwxrwxrwt. 2 root    colord       4096 Oct 17 16:05 systemd-private-62JXdj
drwxrwxrwt. 2 root    root         4096 Oct 17 16:05 systemd-private-vErIEB
drwxrwxrwt. 2 root    colord       4096 Oct 17 15:52 systemd-private-NEddu8
drwxrwxrwt. 2 root    root         4096 Oct 17 15:52 systemd-private-RJY5yC
drwxrwxrwt. 2 root    colord       4096 Oct 17 15:52 systemd-private-FqPzxz
drwxrwxrwt. 2 root    root         4096 Oct 17 15:52 systemd-private-eVah9n
drwxrwxrwt. 2 root    colord       4096 Oct 17 12:39 systemd-private-B806k7
drwxrwxrwt. 2 root    colord       4096 Oct 17 12:39 systemd-private-LhDTjA
drwxrwxrwt. 2 root    root         4096 Oct 17 12:39 systemd-private-XYs3eJ
drwxrwxrwt. 2 root    root         4096 Oct 17 12:39 systemd-private-ibROfw
drwxrwxrwt. 2 root    root         4096 Oct 16 19:00 systemd-private-132B4V
drwxrwxrwt. 2 root    colord       4096 Oct 16 19:00 systemd-private-LnNyqq
drwxrwxrwt. 2 root    colord       4096 Oct 16 19:00 systemd-private-RONuWM
drwxrwxrwt. 2 root    root         4096 Oct 16 19:00 systemd-private-8X479o
drwxrwxrwt. 2 root    colord       4096 Oct 16 15:31 systemd-private-0ZqvYa
drwxrwxrwt. 2 root    root         4096 Oct 16 15:31 systemd-private-bldgON
# 
-----

Expected results: Empty directories systemd-private-* do not accumulate in /var/tmp.


Additional info:
Comment 1 Lennart Poettering 2012-10-18 20:47:43 EDT
Like any other files and directories they are removed by the tmpfiles file cleanup-logic for /tmp. So what am I missing here?
Comment 2 Michal Schmidt 2012-10-19 05:26:51 EDT

*** This bug has been marked as a duplicate of bug 801943 ***

Note You need to log in before you can comment on or make changes to this bug.