Bug 867659 - f18b tc4 anaconda difficulties using the keyboard in the RECLAIM DISK SPACE DIALOG changing the ACTION
f18b tc4 anaconda difficulties using the keyboard in the RECLAIM DISK SPACE D...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 20:31 EDT by Reartes Guillermo
Modified: 2012-10-18 12:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 11:32:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (79.97 KB, image/png)
2012-10-18 12:03 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-17 20:31:14 EDT
Description of problem:

When using just the keyboard, there seems to be some issues at the RECLAIM SPACE dialog. Without using the mouse, i am unable to change the ACTION field.

I reach it, and use SPACE but the DOWN key does not change the field.
Typing 'DELETE' and then pressing ENTER has no effect, it switches back to PRESERVE.


Version-Release number of selected component (if applicable):
F18b TC4

How reproducible:
always

Steps to Reproduce:
See above. 
  
Actual results:
i am unable to change the ACTION from PRESERVE to DELETE for the desired partitions.

Expected results:
Being able to.

Additional info:
If it can be done in some form, i am afraid i could not see how to do it. :-(
Comment 1 Chris Lumens 2012-10-18 11:32:28 EDT
It is a little awkward, but here's how you can do it:

* Press up/down to get to the filesystem you want to modify.
* Press right to go over to the Action column.
* Press enter and the drop-down will appear.
* Press up/down to select the action you want.
* Press enter again and the drop-down will disappear.

You're now in the Action column, so you can just keep pressing down to get to the next filesystem and then press enter when you get to the one you want.
Comment 2 Reartes Guillermo 2012-10-18 12:03:39 EDT
Created attachment 629541 [details]
screenshot

* Press up/down to get to the filesystem you want to modify.
OK

* Press right to go over to the Action column. 
OK

* Press enter and the drop-down will appear.
NOP, same as before

* Press up/down to select the action you want.
Returns to default 'preserve'

* Press enter again and the drop-down will disappear.
I do not reach the stage, because i never see the list.

Additional Info:

On the screenshot, the 'vertical arrow' of the combo is grayed out.

Additionally i can type whatever i want, but when i press enter 
it returns to 'preserve'.

When i use the mouse to display the combo list it is not grayed out
but solid black.

I will try again when TC5 comes out, but it looks like there is something wrong.
Comment 3 Chris Lumens 2012-10-18 12:07:49 EDT
What anaconda are you using?  anaconda-18.17-1 includes a change to that combo box that removes the ability to type in your own text, since that's silly.  You can only do one of the three options we provide.  I bet that's tripping you up here.
Comment 4 Reartes Guillermo 2012-10-18 12:10:28 EDT
I am using F18b TC4, since TC5 is not yet released.

Note You need to log in before you can comment on or make changes to this bug.