Bug 867693 - USB keyboard deactivated during LUKS passphrase prompt [NEEDINFO]
USB keyboard deactivated during LUKS passphrase prompt
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel-module-thinkpad (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jason Carpenter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 01:53 EDT by rob
Modified: 2015-04-13 10:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:37:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rob.hva: needinfo? (extras-qa)


Attachments (Terms of Use)

  None (edit)
Description rob 2012-10-18 01:53:30 EDT
Description of problem:
When trying to boot the kernel-3.6.1-1.fc17.x86_64 my usb keyboard is deactivated during the LUKS passphrase prompt. No passphrase can be given. The keyboard was available in Grub to select a Kernel and it works after F17 is done booting.

The usb keyboard worked (during the LUKS passphrase prompt) in all previous versions (up to kernel-3.5.6-1.fc17.x86_64).

Version-Release number of selected component (if applicable):
kernel-3.6.1-1.fc17.x86_64

How reproducible:

Steps to Reproduce:
1. Start Laptop
2. Select kernel-3.6.1-1.fc17.x86_64 at Grub selection screen
3. Try to enter the required LUKS passphrase
  
Actual results:
No passphrase can be given. As a workaround I now switched back to kernel-3.5.6-1.fc17.x86_64  

Expected results:
Ability to enter the passphrase.

Additional info:
Using a Lenovo Thinkpad T420 icw a Lenovo Thinkpad USB Keyboard (SK-8855)
Comment 1 rob 2012-10-22 05:41:38 EDT
This also applies to kernel-3.6.2-4.fc17.x86_64
Comment 2 rob 2012-10-30 02:38:39 EDT
This also applies to kernel-3.6.3-1.fc17.x86_64
Comment 3 rob 2012-11-09 02:57:43 EST
This also applies to kernel-3.6.5-1.fc17.x86_64

I noticed that this issue does not occur icw a similar keyboard which is the: IBM Thinkpad USB Keyboard (SK-8845). In both cases I am using the exact same USB port.

Note: The IBM version of this keyboard is much older than the Lenovo one.

I hope this additional information helps to determine the root cause of this issue.
Comment 4 rob 2012-11-26 03:09:19 EST
This also applies to kernel-3.6.7-4.fc17.x86_64
Comment 5 rob 2012-12-03 06:36:08 EST
This also applies to 3.6.8-2.fc17.x86_64
Comment 6 rob 2013-01-07 08:46:39 EST
This still applies to 3.6.11-1.fc17.x86_64
Comment 7 rob 2013-01-21 01:44:05 EST
Still applies to 3.6.11-5.fc17.x86_64
Comment 8 rob 2013-01-31 02:56:10 EST
This issue still applies to 3.7.4-204.fc18.x86_64 (after upgrade to Fedora 18, using fedup).
Comment 9 Jacobo Aragunde 2013-09-19 04:15:56 EDT
I have the same issue with a SK-8855 keyboard, using F19 with any of the kernel versions it provides (currently 3.10.11).

I have also noticed that other external keyboards don't have this problem (I've tried several makes and models).
Comment 10 Fedora End Of Life 2013-12-21 04:08:40 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Jacobo Aragunde 2013-12-22 06:26:18 EST
This bug still happens in F19 with 3.11.10-200.fc19.x86_64 kernel.
Comment 12 Fedora End Of Life 2014-02-05 07:37:29 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.