Bug 8677 - Mouse-movement takes linux down in console and startX hangs,
Summary: Mouse-movement takes linux down in console and startX hangs,
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-20 21:42 UTC by Henrik Tonnesen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 16:53:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Tonnesen 2000-01-20 21:42:25 UTC
My installation of Linux RedHat 6.0 (on a Compaq Presario 5676) has severe
problems with mouse-movements. I first discovered the problem in X-windows
(with Gnome) which would nicely display taskbar and Gnome-help, warn about
be logged in as root - but that's all. No further action is possible, the
pointer don't move, and no keys seems to work (neither ctrl-alt-backspace
nor ctrl-alt-delete).
I've looked everywhere, checked mouseconfig (generic PS/2, with 3-buttons
emulation), ls -las /dev/mouse -> /dev/psaux.
I've tried `gpm stop' and `gpm start' before X, even `gmp -K' no
difference. All configfiles seems to state PS/2-mouse.
Furthermore, in mouseconfig, i turned the mouse to check type (Logitech M-
S48) which promptly took linux down.
As a last resort i downloaded the stuff from updates/6.0/i386 installed
kernel to 2.2.5-22 and updated the rest - no luck.

The funny thing is that my Windows 98 works perfectly (well mouse only,
naturally ;-). But my Windows NT installation cannot initialize the mouse -
 it don't crash, so i can live with that.
Does that point to some hardware problem? The mouse or the port?

I can supply further information as long as no Xwindows stuff are required.

Comment 1 Matt Wilson 2000-02-09 06:56:59 UTC
Exactly what kind of mouse do you have?

Comment 2 Henrik Tonnesen 2000-02-19 19:27:59 UTC
The topside states COMPAQ and the bottom Logitech Model M-S48 plus various
ID's, PAT's and PIN's. It's connect through the PS/2-port, which also is
detected at boot.

Since i reported the error i've tried to disable some services (NFS, and the
one giving mouse-support in mc and others) but, alas, no change.

I've seen some advice to change protocol, `kickstart' mouseconfig before X or
try XFRee 3.3.6.

Henrik Tonnesen

Comment 3 Henrik Tonnesen 2000-02-19 21:09:59 UTC
I've found some references that states that some M-S48 mice are OEM version
even without `OEM' labeled on the mouse. Could my mouse, which were bundled
with the computer be an OEM-version?
These numbers are found on the label.
  FCC-Id DZL211153
  Assy P/N 334684-001
  Spares P/N 334689-001
  C/T F18060A5BHGLMZ
  4862A096

None of my previous tries have made me wiser...
I've tried selecting `no mouse' - but X failes to start (cannot find mouse)
New user and fresh config - hangs anyway
Changed sysconfig/mouse (IMPS/2) - hangs anyway
Changed X11/XFConfig (IMPS/2) - hangs anyway
Tried to enter standby mode (through button on the front) after re-igniting
(!?) the screensaver started - but no input are received...

Comment 4 Henrik Tonnesen 2000-02-20 19:18:59 UTC
Further experiments proves that linux is up-and-running. Simply initiating a
delayed shutdown in one terminal and starting X in another; X starts up, opens
my home-folder and some Gnome-windows - but that's all. No keyboard or mouse
activity reach the X server. The shutdown comes into action and brings the
system to a halt. A nicer scheme would include a crontab entry, which should
`killall enlightenment' and other processes startet, this works allright too
and after a sudden exit from X the keyboard functions again.

I tried to connect a cordless logitech mouseman pro to the PS/2 port - but that
seemed to make things worse. After logging in the light on the receiver
flickers and then disables the keyboard (or takes linux down).

Comment 5 Henrik Tonnesen 2000-02-21 11:24:59 UTC
Somehow there are similarities to bug 3678 - but i never get keyboard nor mouse
input through.

I'll try some other mice today - to see if that makes a difference.

Comment 6 Trond Eivind Glomsrxd 2000-08-06 23:35:05 UTC
Dit it?

Comment 7 Mario Minutolo 2001-09-25 10:57:56 UTC
I have mostly the same problem , even a little worse.
I have installed a handfull of time Linux RH 7.1 on a P133. While setting up 
the OS, mouse and keyboard worked perfectly well, even Xtest gave me good 
results but I could not log in with the graphical interface since no imput 
device was responding.

I started a process of trials and errors until I found that the system worked 
with the X server only and even with "some" gnome on. Than I had installed a 
bunch of gnome applications and the problem came back. Worse than that even 
moving mouse on console caused my pc to hang. 

I have disabled gpm to make some more trial and error and I came with some more 
problem. Mousconfig doesn't work well, it gives me a parse error on the line 5 
wich is DEVICE=/dev/mouse. The strange thig is that if I delete that line and 
configure the mouse the same line come back again.

I'm getting really mad about that since I have installed RH7.1 on other 
machines with no such problem, and I'm no close to solve it.

I don't really want to reinstall the whole thing again knowing it will not 
solve the problem. 

There must be some something wrong in mouseconfig but I can't tell what.

Comment 8 Need Real Name 2002-06-26 17:05:39 UTC
Hi, I have the same problem.
I have installed Linux RH 7.3 on a Siemens ProD5 P166 with 256 Ram.
While setting up the OS, mouse (MSIntelliMouse or other Mouse i try a lot 
of...) and keyboard worked perfectly well, even Xtest gave me good 
results but I could not log in with the graphical interface since no input 
device was responding.
My experience with Linux is stopped here.....



Comment 9 Brent Fox 2002-09-10 20:13:54 UTC
This bug is so old and encompasses so many different pieces of software (such as
enlightenment, which we don't even ship anymore) that I think it is impossible
to address this report in a meaningful way.  I'm going to close it as
'worksforme'.  If anyone is still having mouse problems, please open a new bug
report against our new mouse tool (redhat-config-mouse).


Note You need to log in before you can comment on or make changes to this bug.