Bug 867702 - [FEAT]: "gluster volume heal <volume_name> info heal-failed" command and it's output is misleading
[FEAT]: "gluster volume heal <volume_name> info heal-failed" command and it's...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
2.0
Unspecified Unspecified
medium Severity urgent
: ---
: ---
Assigned To: vsomyaju
spandura
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 02:45 EDT by spandura
Modified: 2016-09-17 08:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-11 01:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandura 2012-10-18 02:45:53 EDT
Description of problem:
========================
"gluster volume heal <volume_name> info heal-failed" command means the command output lists all files that were failed to self-heal. i.e.  self-heal daemon failed to self-heal the file. 

Even though the self-heal could have failed on a file in the current crawl, it doesn't mean the self-heal on that file failed for ever. The output is kind of misleading. 

Either the command itself can be changed or the output can be changed to list the files only for which the self-heal really failed because of some reason.

Documentation Link: https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/sect-User_Guide-Managing_Volumes-Self_heal.html

If we see the output of "info healed" and "info heal-failed" the file 
"/dir/file.44"  appears in both the commands.The time of the heal successful is same as time of heal failed. This is confusing in understanding whether the heal was successful or heal failed ?
Comment 2 spandura 2014-06-11 01:26:12 EDT
The command "gluster volume heal <volume_name> info heal-failed" is not supported anymore from the gluster build : 

"[root@rhs-client11 ~]# gluster --version
glusterfs 3.6.0.15 built on Jun  9 2014 11:03:54"

Refer to bug : https://bugzilla.redhat.com/show_bug.cgi?id=1104486

Hence this bug is not valid anymore. Moving the bug to CLOSED state.

Note You need to log in before you can comment on or make changes to this bug.