Bug 867803 - rhui-debug.py should not collect /var/log/httpd
rhui-debug.py should not collect /var/log/httpd
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: 2.1.1
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 06:23 EDT by Bryn M. Reeves
Modified: 2013-02-27 11:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The rhui-debug script collected contents from /var/log/httpd and caused content duplication. The fix updates rhui-debug.py and removes the collection of files under /var/log/httpd.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 11:59:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2012-10-18 06:23:02 EDT
Description of problem:
The rhui-debug.py script is intended to be called from sosreport to gather rhui-specific diagnostic data from systems.

The current version collects the /var/log/httpd directory:

Copying contents of directory [/var/log/httpd/] to [/tmp/rhui-debug-2012-08-03-T11-26-40/var/log/httpd/]

This duplicates the functionality of the sos httpd module - this will automatically collect these logs when the package is installed meaning that we will have two copies of a potentially large directory in the resulting archive.

We should remove this in a future update to ensure to keep the tarball size down to a minimum.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. Run "python /usr/share/rh-rhua/rhui-debug.py"
2. Note paths collected
  
Actual results:
Paths include /var/log/httpd

Expected results:
Paths only include rhui-specific files

Additional info:
Comment 1 Sayli Karmarkar 2012-10-18 15:36:23 EDT
Fixed

commit 8873b805a0c6953bff9892ce8eb66668f13df762
Author: Sayli Karmarkar <skarmark@redhat.com>
Date:   Thu Oct 18 12:35:45 2012 -0700

    867803 - removing collection of files under /var/log/httpd from rhui-debug script since sosreport collects it by default when httpd is installed
Comment 2 Todd Sanders 2012-10-19 07:19:58 EDT
Moving over to 2.1.1, so we pick this up during the planned release cycle.
Comment 3 Vitaly Kuznetsov 2013-02-04 08:17:46 EST
[root@rhua ~]# rpm -q rh-rhui-tools 
rh-rhui-tools-2.1.15-1.el6_3.noarch

[root@rhua ~]# python /usr/share/rh-rhua/rhui-debug.py | grep '/var/log/httpd/' | wc -l
0
Comment 5 errata-xmlrpc 2013-02-27 11:59:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0571.html

Note You need to log in before you can comment on or make changes to this bug.