Bug 867820 - realm crashes when realmd.conf contains empty computer-ou
realm crashes when realmd.conf contains empty computer-ou
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
18
All Linux
high Severity high
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 07:13 EDT by Miroslav Vadkerti
Modified: 2012-12-20 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:11:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grep realmd /var/log/audit/audit.log > audit.log (26.09 KB, text/plain)
2012-10-18 09:33 EDT, Petr Sklenar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 56162 None None None 2012-10-19 00:53:47 EDT

  None (edit)
Description Miroslav Vadkerti 2012-10-18 07:13:20 EDT
Description of problem:
The realm crashes if blank computer-out used

# cat /etc/realmd.conf
[radi08.segad.lab.sjc.redhat.com]
computer-ou = 

# realm --verbose join --user=Zoidberg radi08.segad.lab.sjc.redhat.com
 * Searching for kerberos SRV records for domain: _kerberos._udp.radi08.segad.lab.sjc.redhat.com
 * Searching for MSDCS SRV records on domain: _kerberos._tcp.dc._msdcs.radi08.segad.lab.sjc.redhat.com
 * ad1.radi08.segad.lab.sjc.redhat.com:88 
 * Found kerberos DNS records for: radi08.segad.lab.sjc.redhat.com
 * Found AD style DNS records for: radi08.segad.lab.sjc.redhat.com
 * Successfully discovered: radi08.segad.lab.sjc.redhat.com
Password for Zoidberg: 
 * Required files present: /usr/sbin/sss_cache, /usr/sbin/sssd, /usr/bin/net
realm: Couldn't join realm: Message did not receive a reply (timeout by message bus)

Version-Release number of selected component (if applicable):
realmd-0.9-1.fc18

How reproducible:
100% on my virtual machine

Steps to Reproduce:
1. install realmd
2. have an AD handy
3. set realmd.conf with blank computer-ou
  
Actual results:
realm: Couldn't join realm: Message did not receive a reply (timeout by message bus)
That seems to be a crash as abrt detected it

Expected results:
No crash

Additional info:
Comment 1 Petr Sklenar 2012-10-18 09:33:37 EDT
Created attachment 629380 [details]
grep realmd /var/log/audit/audit.log > audit.log

I could see many of the selinux denials during similar cmd:
realm join --user=Administrator X.Y.Z

machine was freshly installed f18 with:
# rpm -q realmd selinux-policy
realmd-0.9-1.fc18.x86_64
selinux-policy-3.11.1-35.fc18.noarch
Comment 2 Fedora Update System 2012-10-20 02:44:43 EDT
realmd-0.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/realmd-0.10-1.fc18
Comment 3 Fedora Update System 2012-10-21 01:57:34 EDT
Package realmd-0.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing realmd-0.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16542/realmd-0.10-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-10-30 14:51:21 EDT
realmd-0.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/realmd-0.11-1.fc18
Comment 5 Fedora Update System 2012-12-20 11:11:06 EST
realmd-0.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.