Bug 867885 - Disable client-side mouse acceleration temporarily when the pointer is in server mode and grabbed
Disable client-side mouse acceleration temporarily when the pointer is in ser...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: beta
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 09:49 EDT by David Jaša
Modified: 2013-07-03 08:09 EDT (History)
10 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 872135 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:49:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-10-18 09:49:19 EDT
Description of problem:
Disable client-side mouse acceleration temporarily when the pointer is in server mode and grabbed. Spice-gtk doesn't seem to do it and it causes weird pointer behaviour in server mode (from overly sensitive cursor when acceleration curves shape is smooth and similar to erratic behaviour).

Version-Release number of selected component (if applicable):
spice-gtk-0.14-3.el6.x86_64
virt-viewer-0.5.2-11.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. make sure you have mouse speeds at highest possible levels in mouse properties and mouse acceleration enabled ("acceleration" slider at maximum value in gnome mouse properties, in Windows "Enhance pointer precision" checkbox)
2. make sure you have mouse in server mode
3. move mouse semi-quickly
  
Actual results:
mouse pointer will almost "jump" over whole guest desktop at any faster movement

Expected results:
mouse pointer should move in a guest just as it would move in a physical client

Additional info:
This could affect windows client as well
Comment 1 Marc-Andre Lureau 2012-10-18 14:04:27 EDT
Hmpf, we have already http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=e34ebd9da4130147927eeab47ba3c4d0d2010db7

Hans? :)
Comment 2 Marc-Andre Lureau 2012-10-18 14:46:41 EDT
I sent a fix on the ML for X11
Comment 3 Marc-Andre Lureau 2012-10-18 15:17:55 EDT
added support for windows, sent to ML
Comment 4 Hans de Goede 2012-10-19 05:55:08 EDT
(In reply to comment #1)
> Hmpf, we have already
> http://cgit.freedesktop.org/spice/spice-gtk/commit/
> ?id=e34ebd9da4130147927eeab47ba3c4d0d2010db7
> 
> Hans? :)

See my response to yuor patch on the ML.
Comment 7 Marc-Andre Lureau 2012-12-10 08:07:36 EST
Fixed in spice-gtk-0.14-5.el6
Comment 11 errata-xmlrpc 2013-02-21 03:49:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html
Comment 12 Luixo 2013-04-10 06:55:09 EDT
Bug still persist on:
spice-gtk-0.18-1.fc18.x86_64
virt-viewer-0.5.4-3.fc18.x86_64
from fedora18-updates repository.
Comment 13 Marc-Andre Lureau 2013-06-14 18:24:21 EDT
*** Bug 872135 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.