Bug 867891 - ValueError: ('invalid size specification', '0 b')
ValueError: ('invalid size specification', '0 b')
Status: CLOSED DUPLICATE of bug 865849
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f5964ed7068fb5ebaf7221a2a45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 09:55 EDT by Ladislav Jozsa
Modified: 2012-11-05 15:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 15:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: anaconda-tb (231.62 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: product (6 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: type (9 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: environ (764 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: storage.log (74.67 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: version (11 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: program.log (32.08 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: anaconda.log (5.21 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: syslog (86.36 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details
File: release (24 bytes, text/plain)
2012-10-18 09:55 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2012-10-18 09:55:10 EDT
Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 99, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 117, in size_str
:    return str(Size(spec=spec)).upper()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 160, in _set_free_space_labels
:    fs_free_text = size_str(fs_free)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 237, in refresh
:    self._set_free_space_labels(disks_size, disk_free, fs_free)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 627, in on_continue_clicked
:    dialog.refresh(required_space, disks_size, disk_free, fs_free, self.autopart)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 676, in on_continue_clicked
:    self.on_continue_clicked(button)
:ValueError: ('invalid size specification', '0 b')
Comment 1 Ladislav Jozsa 2012-10-18 09:55:13 EDT
Created attachment 629413 [details]
File: ifcfg.log
Comment 2 Ladislav Jozsa 2012-10-18 09:55:17 EDT
Created attachment 629414 [details]
File: anaconda-tb
Comment 3 Ladislav Jozsa 2012-10-18 09:55:21 EDT
Created attachment 629416 [details]
File: product
Comment 4 Ladislav Jozsa 2012-10-18 09:55:23 EDT
Created attachment 629417 [details]
File: type
Comment 5 Ladislav Jozsa 2012-10-18 09:55:26 EDT
Created attachment 629418 [details]
File: environ
Comment 6 Ladislav Jozsa 2012-10-18 09:55:28 EDT
Created attachment 629419 [details]
File: storage.log
Comment 7 Ladislav Jozsa 2012-10-18 09:55:30 EDT
Created attachment 629420 [details]
File: version
Comment 8 Ladislav Jozsa 2012-10-18 09:55:33 EDT
Created attachment 629421 [details]
File: program.log
Comment 9 Ladislav Jozsa 2012-10-18 09:55:36 EDT
Created attachment 629422 [details]
File: anaconda.log
Comment 10 Ladislav Jozsa 2012-10-18 09:55:38 EDT
Created attachment 629423 [details]
File: syslog
Comment 11 Ladislav Jozsa 2012-10-18 09:55:41 EDT
Created attachment 629424 [details]
File: hashmarkername
Comment 12 Ladislav Jozsa 2012-10-18 09:55:43 EDT
Created attachment 629425 [details]
File: packaging.log
Comment 13 Ladislav Jozsa 2012-10-18 09:55:45 EDT
Created attachment 629426 [details]
File: cmdline_file
Comment 14 Ladislav Jozsa 2012-10-18 09:55:47 EDT
Created attachment 629427 [details]
File: release
Comment 15 Adam Williamson 2012-11-05 15:03:49 EST
dlehman believes this is the same as 865849, and further that the issue should be fixed in recent anaconda builds. If you can reliably reproduce this (you know what partitioning configuration and anaconda path causes it), can you try with TC7 and report to 865849 whether it's fixed? Thanks!

*** This bug has been marked as a duplicate of bug 865849 ***

Note You need to log in before you can comment on or make changes to this bug.