Bug 867894 - Please update to version 3.4.0
Please update to version 3.4.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-decorator (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 866183
  Show dependency treegraph
 
Reported: 2012-10-18 10:00 EDT by Brendan Jones
Modified: 2012-12-20 11:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:14:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brendan Jones 2012-10-18 10:00:48 EDT
Version 3.4.0 corrects a bug I've uncovered as part of review bug 866183.

thanks,
Comment 1 Toshio Ernie Kuratomi 2012-10-18 14:17:47 EDT
Which releases do you need this updated on?  I just reviewed the changes in the package.  I can definitely push this to rawhide and I'm willing to push it to F18.  I can be convinced to push it further back but there is one backwards incompatible API change so I'd like to know if it was needed first.
Comment 2 Brendan Jones 2012-10-18 16:36:39 EDT
I was going to push the new package to at least F17, but I don't really mind if we stop at F18. 

The bug in question affects python3 only so we will still have a working package with python2
Comment 3 Toshio Ernie Kuratomi 2012-10-18 17:35:16 EDT
It's fine with me to push to F17.  I'll leave it in updates-testing for the full two weeks (for F17) but there's a straightforward fix if there's any problems.

(The package dropped a partial function that was used as backwards compat on older versions of python.  Since all current Fedora uses python-2.7, people can just port their code to try importing partial from the stdlib first.)
Comment 4 Fedora Update System 2012-10-18 17:37:52 EDT
python-decorator-3.4.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-decorator-3.4.0-1.fc17
Comment 5 Fedora Update System 2012-10-18 17:38:02 EDT
python-decorator-3.4.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-decorator-3.4.0-1.fc18
Comment 6 Fedora Update System 2012-10-19 11:44:17 EDT
Package python-decorator-3.4.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-decorator-3.4.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16480/python-decorator-3.4.0-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 11:14:06 EST
python-decorator-3.4.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.