This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 867928 - CFCE User Guide section 4.2.3 Setting Up a Cloud Resource Provider Connection update
CFCE User Guide section 4.2.3 Setting Up a Cloud Resource Provider Connection...
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Dan Macpherson
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 11:15 EDT by Aaron Weitekamp
Modified: 2012-12-10 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Filter: null Build Name: 9920, Cloud Engine User Guide-1.1-1 Build Date: 17-10-2012 02:10:31
Last Closed: 2012-12-10 17:10:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Weitekamp 2012-10-18 11:15:26 EDT
Description of problem:
The instructions in CFCE user guide [1] only work for creating a new EC2 cloud resource provider. RHEVM and Vsphere require a config file edit and a re-run of aeolus-configure -p [rhevm|vsphere] per install guide [2].

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/CloudForms/1.1/html/Cloud_Engine_User_Guide/sect-Provider_Connections.html

[2] http://documentation-devel.engineering.redhat.com/docs/en-US/CloudForms/1.1/html/Installation_Guide/appe-Private_Cloud_Configuration.html

Version-Release number of selected component (if applicable):
1.1


Steps to create new vsphere or rhevm cloud resource provider:
1. edit /etc/aeolus-configure/nodes/rhevm_configure or /etc/aeolus-configure/nodes/vsphere_configure
2. run aeolus-configure -p [vsphere|rhevm]

We need to verify that re-running aeolus-configure doesn't break anything. For example, if in LDAP mode does aeolus-configure revert the config back to local users?
Comment 2 Dan Macpherson 2012-10-18 14:22:43 EDT
(In reply to comment #0)
> Description of problem:
> The instructions in CFCE user guide [1] only work for creating a new EC2
> cloud resource provider. RHEVM and Vsphere require a config file edit and a
> re-run of aeolus-configure -p [rhevm|vsphere] per install guide [2].

...

> Steps to create new vsphere or rhevm cloud resource provider:
> 1. edit /etc/aeolus-configure/nodes/rhevm_configure or
> /etc/aeolus-configure/nodes/vsphere_configure
> 2. run aeolus-configure -p [vsphere|rhevm]

I can place a reference from this procedure citing the Appendix in the Installation Guide for configuration instructions.

I'll also add the aeolus-configure -p [vsphere|rhevm] to the Appendix in the Installation Guide.

> We need to verify that re-running aeolus-configure doesn't break anything.
> For example, if in LDAP mode does aeolus-configure revert the config back to
> local users?

I wouldn't say this is a documentation bug just yet. This sounds more like a software bug because, theoretically, an admin should be able to run aeolus-configure without affecting LDAP settings.

I'd recommend testing this and, if the problem exists, opening a bug to fix the issue. However, if this is something that can't be fixed before 1.1, we can add some documentation (possibly as a Release Note).
Comment 3 Dan Macpherson 2012-10-18 15:05:39 EDT
Changed relevant content in book. Will be available next brew of the book.
Comment 5 Aaron Weitekamp 2012-10-19 09:17:26 EDT
Re-running aeolus-configure -p vsphere|rhevm reverts authorization mode to database. So if LDAP, one needs to edit the files and restart services.
1. edit /etc/aeolus-conductor/settings.yml  
2. edit /etc/ldap_fluff.yml     
3. `aeolus-services restart`
Comment 6 James Laska 2012-10-19 11:18:31 EDT
(In reply to comment #5)
> Re-running aeolus-configure -p vsphere|rhevm reverts authorization mode to
> database. So if LDAP, one needs to edit the files and restart services.
> 1. edit /etc/aeolus-conductor/settings.yml  
> 2. edit /etc/ldap_fluff.yml     
> 3. `aeolus-services restart`

Or include the desired LDAP command-line arguments when re-running aeolus-configure?  Although I think we already document setting up LDAP using the method described in comment#5.  Probably best to stick with that?
Comment 7 Mike Orazi 2012-10-23 09:55:26 EDT
Agree that sticking with the suggestion in comment 5 & the existing docs is probably the best idea at this point.
Comment 8 Dan Macpherson 2012-10-23 10:24:43 EDT
Does aeolus-configure overwrite the /etc/ldap_fluff.yml file or not? I would assume not since aeolus-configure doesn't seem to touch LDAP settings (yet), which means step 2 in comment #5 of the above bug isn't needed. This would be a good thing since rewriting the LDAP settings each time you run aeolus-configure is a little cumbersome.
Comment 11 Lana Brindley 2012-11-18 21:45:45 EST
This documentation has now been dropped to translation ahead of publication. For any further issues, please open a new a bug.

LKB
Comment 12 Lana Brindley 2012-12-10 17:10:55 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.