Bug 867947 - vdsClient should not show storage domains not in the storage pool
vdsClient should not show storage domains not in the storage pool
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.0.7
x86_64 Linux
unspecified Severity low
: ---
: 3.1.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 12:09 EDT by Dafna Ron
Modified: 2016-02-10 12:59 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 11:09:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (637.14 KB, application/x-gzip)
2012-10-18 12:09 EDT, Dafna Ron
no flags Details
logs (667.18 KB, application/x-gzip)
2012-10-21 11:22 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-18 12:09:33 EDT
Created attachment 629542 [details]
logs

Description of problem:

running vdsClient -s 0 getStorageDomainsList in both my hosts I see 9 domains in spm and 8 in hsm. 
the domain not showing is a domain which is unattached to the pool (see screen shot attached on 9 domains and attached files showing only 8 in hsm) 
after speaking to Edu he thinks its a backend bug so opening on backend. 

Version-Release number of selected component (if applicable):

si21
vdsm-4.9.6-38.0.el6_3.x86_64
libvirt-0.9.10-21.el6_3.5.x86_64
lvm2-2.02.95-10.el6.x86_64
lvm2-libs-2.02.95-10.el6.x86_64

How reproducible:

not sure. 

Steps to Reproduce:
1. add domains to DC with only one host + create domains but do not attach them
2. after domains are active add a second host to DC (do not install, just move from different DC). 
3.
  
Actual results:

we see different results of domains in vgs

Expected results:

both hosts should have same results

Additional info: logs, vgs, device list, domains list from both hosts are attached
Comment 1 Eduardo Warszawski 2012-10-21 08:51:27 EDT
The LUNs view from hosts gold-vdsc(spm) and gold-vdsd(hsm) is different.
Is required for the proper function of the system to the two views to be identical.
Please check the storage configuration.


LUN 3600140531258b628dbb4710b04713bb7 can't be seen in gold-vdsd.

This LUN contains VG 47c27c7e-6238-4d0e-8d62-d97c5c2e93ee which is the SD named "testi-01"

This is the lacking SD.

In spite that the connections are identical two luns are not exposed by the LIO_ORG,IBLOCK target to the gold-vdsd host.

gold-vdsc:
3600140531258b628dbb4710b04713bb7 dm-72 LIO-ORG,IBLOCK
360014052ebfb4b09b1b488f80ccae54c dm-106 LIO-ORG,IBLOCK
36001405fadabd60ec0e4369b3e61eba5 dm-105 LIO-ORG,IBLOCK
360014058faf7546269744f582b3366fa dm-104 LIO-ORG,IBLOCK

gold-vdsd:
36001405fadabd60ec0e4369b3e61eba5 dm-108 LIO-ORG,IBLOCK
360014058faf7546269744f582b3366fa dm-109 LIO-ORG,IBLOCK

Active connections in the two hosts:
testi-dafna
iscsi_export_domain
iqn.2003-01.org.linux-iscsi.tiger.x8664:sn.20121007131413.Dafna
Dafna-si21-03
Dafna-02
Dafna-01
Dafna-New2
Dafna-04
Dafna-03
Dafna-New1

SDs in gold-vdsc:
'dbed4cf3-a177-49a8-b41c-f12b85db4286', '47c27c7e-6238-4d0e8d62-d97c5c2e93ee', 'd95cd4e5-166a-4901-84f5-64eaca97d4c6', 'ede8ec4d-ba09-48df-ad0a-7c1e978d4a7c', '402471a6-154f-43a3-b9fe-5308024c33a6', '169e9862-88c7-4ba2-84ce-b7efdb298ab0', '76f6a2e6-e2a3-431c-a8ef-f5d58aa00629', 'ac6943fb-d267-45c3-a5af-128a6e761a2e', '597dd01f-c2fc-47b1-b19a-c3eec053d336', 'fb891cd0-355f-4584-a8c4-de7fdab3e47b'

SDs in gold-vdsd:
'dbed4cf3-a177-49a8-b41c-f12b85db4286', '402471a6-154f-43a3-b9fe-5308024c33a6', 'd95cd4e5-166a-4901-84f5-64eaca97d4c6', 'ede8ec4d-ba09-48df-ad0a-7c1e978d4a7c', '169e9862-88c7-4ba2-84ce-b7efdb298ab0', '76f6a2e6-e2a3-431c-a8ef-f5d58aa00629', 'ac6943fb-d267-45c3-a5af-128a6e761a2e', '597dd01f-c2fc-47b1-b19a-c3eec053d336'
Comment 2 Dafna Ron 2012-10-21 11:17:57 EDT
I managed to reproduce. 
1. hsm only shows domains in pool when we run vgs. if we detach a domain hsm will no longer show it. 
2. put hsm host in maintenance -> put domains in maintenance -> detach domains
the hsm will still show the connection of the luns when running iscsiadm -m session but vgs will show only domains in pool 

attaching logs
Comment 3 Dafna Ron 2012-10-21 11:22:20 EDT
Created attachment 630915 [details]
logs
Comment 4 Ayal Baron 2012-10-23 18:27:39 EDT
Dafna,

I could not make heads or tails of this bug.
What exactly is the problem?
When you create a domain but do not attach it to another host, why would you expect to see it on other hosts?
Comment 5 Haim 2012-10-24 02:35:14 EDT
(In reply to comment #4)
> Dafna,
> 
> I could not make heads or tails of this bug.
> What exactly is the problem?
> When you create a domain but do not attach it to another host, why would you
> expect to see it on other hosts?

Ayal, the problem is as follows:

- we have a pool with several domains and 2 hosts
- we detach one of the domains:
  - maintenance 
  - detach
- from some-reason, engine send connectStorageServer to this domain (in detached state) to one of the hosts, hence, domain (VG) is visible on that host.

expected result: engine should not try to connect this server, up until user asks for it and tries to attach it to pool again. 

in any case, this implies on an inconsistent behavior where engine send the connect to one of the hosts and not the other.
Comment 6 Dafna Ron 2012-10-24 03:05:20 EDT
I have two hosts in one cluster with 8 domains attached to pool and two unattached. 

when I ran vdsClient from both hosts I could see 8 domains in one host and 9 domains in the other. 
vdsClient reported 1 or the unattached domains in one host although it was not part of the pool (it is in the setup but not in the pool). 

this is all the bug is about - do not show domains which are not connected to the pool in vdsClient
Comment 7 Allon Mureinik 2013-06-25 09:21:49 EDT
> this is all the bug is about - do not show domains which are not connected
> to the pool in vdsClient
Changing component and rephrasing title based on this comment
Comment 8 Nir Soffer 2013-12-11 02:27:15 EST
Does is happens in 3.3?
Comment 9 Dafna Ron 2013-12-11 06:50:35 EST
(In reply to Nir Soffer from comment #8)
> Does is happens in 3.3?

Please direct questions to Aharon since I am no longer working on rhevm.
Comment 10 Aharon Canan 2013-12-17 04:18:19 EST
using 3.3 is27, 
both SPM and HSM show all SDs (attached and Unattached) the same

I am not sure if we want to see the unattached domains when running vgs or vdsClient.

1. created ISCSI DC with 2 hosts
2. added 5 SDs (few attached few unattached)
3. run vgs and vdsClient
Comment 11 Nir Soffer 2013-12-17 04:23:19 EST
(In reply to Aharon Canan from comment #10)
> using 3.3 is27, 
> both SPM and HSM show all SDs (attached and Unattached) the same
> 
> I am not sure if we want to see the unattached domains when running vgs or
> vdsClient.

vgs will show everything lvm sees, we cannot and do not want to change that.

But limiting domains in vdsClient sounds reasonable.
Comment 12 Federico Simoncelli 2013-12-17 10:43:17 EST
I don't think this is a bug (nor that we should do anything at all).

WRT to getStorageDomainsList returns (by design) all the visible storage domains. If you specify an (optional) storage pool, then it displays only the relevant storage domains (part of the pool).

E.g.:

# vdsClient 0 getStorageDomainsList
c8c60dca-3ec8-4ea0-8135-d929070055cb
cabee123-519e-4330-b3c0-d4e4295c7744
70951c4d-489a-4b3b-bbe5-11dedd05243c
eb6a491a-4dd1-4751-b1d6-5ac3be1a54aa
864df2d0-b022-435f-a9d1-b7ac0bd766bb

# vdsClient 0 getStorageDomainsList 98da1408-948d-4cab-9a8b-418914be9f07
c8c60dca-3ec8-4ea0-8135-d929070055cb
864df2d0-b022-435f-a9d1-b7ac0bd766bb


As far as I know the engine is aware of this behavior.

Note You need to log in before you can comment on or make changes to this bug.