Bug 867965 - request to add build/deploy call to the APIs/CLI
request to add build/deploy call to the APIs/CLI
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
: 902112 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 13:26 EDT by Nam Duong
Modified: 2015-05-14 20:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 22:00:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-10-18 13:26:04 EDT
Description of problem:
Good feedback from a user on IRC:
<cschneid> how do you tell openshift to do the whole deploy process again, even without a new git push
nduong> cschneid, there isn't a command on the cli to do that.
<cschneid> nduong: if I ctrl-c out of a git push, it doesn't finish all the scripts, but git push again thinks its done
<nduong> cschneid, I usually just modify the README to keep it simple
<cschneid> sure, that just clutters the git repo though :) for now playing with the platform that works fine
<nduong> cschneid, otherwise, if you know which action-hooks you need to run, I suppose you can ssh onto the gear and run them.

Would be nice to have a CLI command that mimics what git push calls (stop/build/deploy/start)
Comment 1 Sumana Annam 2012-10-25 17:08:06 EDT
During Zend hackathon, few users asked for this. They were not too happy when I told them to make a bogus change and initiate a git push.
Comment 2 Dan McPherson 2013-01-25 19:18:01 EST
*** Bug 902112 has been marked as a duplicate of this bug. ***
Comment 3 Dan McPherson 2013-01-28 22:00:39 EST
US3372 created to track this

Note You need to log in before you can comment on or make changes to this bug.