Bug 867983 - qemu-ga: empty reason string for OpenFileFailed error
qemu-ga: empty reason string for OpenFileFailed error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 15:15 EDT by Luiz Capitulino
Modified: 2013-02-21 02:40 EST (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.330.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:40:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2012-10-18 15:15:24 EDT
Description of problem:

The series that fixed bug 806775, forgot to update qemu-ga and now its reason string for the OpenFileFailed error is empty.


Version-Release number of selected component (if applicable): qemu-kvm-0.12.1.2-2.323.el6


How reproducible:


Steps to Reproduce:
1. Run qemu-ga in the guest and try to open a not existing file:

{ "execute": "guest-file-open", "arguments": { "path": "/tmp/jnaskjd" } }
  
Actual results:

No reason is given:

{ "error": { "class": "OpenFileFailed",
             "desc": "Could not open '/tmp/jnaskjd': ",
             "data": {"filename": "/tmp/jnaskjd",
             "__com.redhat_error_message": "" } } }


Expected results:

Give the error reason:

{ "error": { "class": "OpenFileFailed",
             "desc": "Could not open '/tmp/jnaskjd': No such file or directory",
             "data": { "filename": "/tmp/jnaskjd",
             "__com.redhat_error_message": "No such file or directory" } } }

Additional info:
Comment 4 mazhang 2012-11-07 01:08:47 EST
Reproduced this bug.
qemu-kvm-0.12.1.2-2.316.el6.x86_64.rpm
qemu-guest-agent-0.12.1.2-2.316.el6.x86_64.rpm


Steps to Reproduce:
1. Run qemu-ga in the guest and try to open a not existing file:

{ "execute": "guest-file-open", "arguments": { "path": "/tmp/jnaskjd" } }

Actual results:
[root@m1 ~]# nc -U /tmp/qga.sock 
{ "execute": "guest-file-open", "arguments": { "path": "/tmp/jnaskjd" }}
{"error": {"class": "OpenFileFailed", "data": {"filename": "/tmp/jnaskjd"}}}
Comment 5 mazhang 2012-11-07 01:13:20 EST
Verified this bug on:
qemu-kvm-0.12.1.2-2.334.el6.x86_64.rpm
qemu-guest-agent-0.12.1.2-2.334.el6.x86_64.rpm


Steps:
1. Run qemu-ga in the guest and try to open a not existing file:

{ "execute": "guest-file-open", "arguments": { "path": "/tmp/jnaskjd" } }


Actual results:
[root@m1 ~]# nc -U /tmp/qga.sock
{ "execute": "guest-file-open", "arguments": { "path": "/tmp/jnaskjd" }}
{"error": {"class": "OpenFileFailed", "desc": "Could not open '/tmp/jnaskjd':
No such file or directory", "data": {"filename": "/tmp/jnaskjd",
"__com.redhat_error_message": "No such file or directory"}}


we can got error information:"No such file or directory"
so this bug was fixed.
Comment 7 errata-xmlrpc 2013-02-21 02:40:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.