Bug 868030 - Recommend graphical installation on IBM Power Systems servers
Recommend graphical installation on IBM Power Systems servers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jack Reed
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 19:23 EDT by Jack Reed
Modified: 2013-06-17 01:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 19:19:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Reed 2012-10-18 19:23:41 EDT
As part of our discussions about improving the Power Systems section of the Installation Guide, Brent Baude from IBM's Linux Technology Center emailed me with a suggestion that the Installation Guide recommend using the graphical installer if installing on a graphical display, because on Power Systems anaconda defaults to the text installer.

So QE can compare what I have written with IBM's suggestions, I'll quote the relevant part of Brent's email here:


"I'll suggest some wording that you guys can refine.

'You should strongly consider using the graphical anaconda to install your system.  It is more feature rich and is the preferred installation method for RHEL.  Because POWER systems primarily use text consoles, anaconda will not automatically start a graphical installation.  You can start a graphical install through anaconda by passing an anaconda boot option of 'vnc'.  For more information, see (https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/sn-remoteaccess-installation.html#sn-remoteaccess-installation-vnc)  .  '

If we consider something like that (and I defer to your collective judgement there), then we might consider a slight change to:

'Finally, select the device containing the installation DVD. Yaboot is loaded from this device and you are presented with a boot: prompt. Press Enter or wait for the timeout to expire for the installation to begin.'

And we can hand edit the picture in 14.1 by showing the vnc parameter being passed.

boot:
* linux                    
boot: linux vnc  
Please wait, loading kernel...
"


I will add an admonition to the start of Chapter 14. Booting the Installer, explaining that the graphical installer is recommended on systems with a graphical display and that the vnc boot option is required.

I will edit the sentence regarding the boot: prompt to mention that the vnc boot option can be passed here.

I will also add a second piece of sample output to section 14.1 to include the output Brent provided, to demonstrate the vnc boot option being passed.

These updates will be available in the 6.4 edition of the Installation Guide.
Comment 3 Jack Reed 2013-02-25 19:19:57 EST
This bug has been verified and implemented for 6.4, so I am changing the status to CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.