Bug 868051 - RFE: emit version string on execution with no command
RFE: emit version string on execution with no command
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 20:35 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 20:42:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-10-18 20:35:48 EDT
To check what version of csprocessor is installed / running on a machine, it would be useful to be able to just do: 

csprocessor

currently this returns a help screen,  but no version information. executing a command outputs the version, as does --version.



==============================
Generated Details:

Package: cspclient-0.27.6-1.noarch

OS: Fedora release 16 (Verne)
Comment 1 Lee Newson 2012-10-18 20:42:23 EDT
If you want the version then you should use "csprocessor --version", that's the whole point of that command. If you put an invalid option in (or no option), then it should show help options. As such I see no use for this and you haven't provided any reasoning for this RFE. If you can provide a valid use case outside of not wanting to type "--version" then I'll reconsider.
Comment 2 Joshua Wulf 2012-10-19 02:20:26 EDT
I frequently do bug testing of builds of the csprocessor, and use it on multiple machines. Ascertaining which version is installed / active is a frequent activity, and I regularly find myself issuing "csprocessor" with an /expectation/ that it will give me its version - because other programs that I frequently use do that.

Reporting version along with usage information when invoked with no arguments is a standard design pattern. 

For example:

jwulf@radhe Node-dev]$ nmap
Nmap 6.01 ( http://nmap.org )
Usage: nmap [Scan Type(s)] [Options] {target specification}
TARGET SPECIFICATION: [...]

Adding that doesn't do away with the --version argument. For example, that argument is useful for determining the available version of csprocessor in a script by parsing the output.

Hopefully that makes the rationale clearer.

Note You need to log in before you can comment on or make changes to this bug.