Bug 868054 - Regression: screen crossing for non-Xinerama setups is broken
Summary: Regression: screen crossing for non-Xinerama setups is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
: 867905 (view as bug list)
Depends On:
Blocks: 833212
TreeView+ depends on / blocked
 
Reported: 2012-10-19 01:11 UTC by Peter Hutterer
Modified: 2018-12-01 18:20 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.13.0-7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:04:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
multi-screen-rec.conf (426 bytes, text/plain)
2012-10-19 01:11 UTC, Peter Hutterer
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0299 0 normal SHIPPED_LIVE xorg-x11-server bug fix and enhancement update 2013-02-20 20:35:47 UTC

Description Peter Hutterer 2012-10-19 01:11:28 UTC
Created attachment 629688 [details]
multi-screen-rec.conf

Description of problem:
Pointer screen crossing for non-xinerama setups is broken.


Version-Release number of selected component (if applicable):
xorg-x11-server-1.13.0-5.el6

How reproducible:
The attached config gives a Xorg with two ScreenRecs, independent of each
other. This one uses the dummy driver, please  modified to use the driver of
your choosing.

Steps to Reproduce:
1. xdpyinfo | grep root (note the root window IDs for the two screens)
1. xev -id 0xabc
2. xev -id 0xcde
3. Move the pointer between the screens

Depending on which screen the pointer is on, xev should show the events. At screen crossing, one xev will stop listing events (with LeaveNotify), the other sees an EnterNotify and the motion events.

If using a real driver, the pointer motion can generally be observed as well.
  
Additional info:
Proposed patch upstream: http://patchwork.freedesktop.org/patch/12259/
This is a regression introduced before the 1.13.0 release.

Comment 1 RHEL Program Management 2012-10-19 03:31:08 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 2 Peter Hutterer 2012-10-22 22:13:22 UTC
*** Bug 867905 has been marked as a duplicate of this bug. ***

Comment 4 Peter Hutterer 2012-10-24 04:35:44 UTC
MODIFIED

xorg-x11-server-1.13.0-7.el6 is available in brew

Comment 8 errata-xmlrpc 2013-02-21 08:04:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html


Note You need to log in before you can comment on or make changes to this bug.