Bug 868092 - PULSE_SERVER doesn't forward sound [NEEDINFO]
PULSE_SERVER doesn't forward sound
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 00:30 EDT by gregrwm
Modified: 2017-12-06 06:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:35:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtaymans: needinfo? (rhbugzi)


Attachments (Terms of Use)

  None (edit)
Description gregrwm 2012-10-19 00:30:27 EDT
Description of problem:  fails to forward sound via PULSE_SERVER environment variable


Version-Release number of selected component (if applicable):  pulseaudio-libs      0.9.21  14.el6_3   i686


Steps to Reproduce:
1.  forward port 4716 via ssh to a sound production box
2.  PULSE_SERVER=localhost:4716 ALSA_PCM_NAME=pulse padsp xterm
3.  launch sound app in that xterm, eg mplayer

  
Actual results:
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO_ALSA] alsa-lib: pcm_dmix.c:1000:(snd_pcm_dmix_open) unable to create IPC shm instance
[AO_ALSA] Playback open error: Invalid argument
Failed to initialize audio driver 'alsa'
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1000:(snd_pcm_dmix_open) unable to create IPC shm instance
[AO_ALSA] Playback open error: Invalid argument
[AO ARTS] can't connect to aRts soundserver
[AO ESD] esd_open_sound failed: Connection timed out
AO: [pulse] Init failed: Connection refused
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_dmix.c:1000:(snd_pcm_dmix_open) unable to create IPC shm instance
[AO SDL] Unable to open audio: No available audio device


Expected results:  forward sound via port 4716


Additional info:  works elsewhere eg ubuntu natty
Comment 2 gregrwm 2012-11-04 00:41:32 EDT
also works fine on the CentOS-6.3-i386-LiveCD.  so i bet the issue here is having installed a packageset that satisfied all yum dependencies, but has not installed something needed for remote PULSE_SERVER functionality.
Comment 3 RHEL Product and Program Management 2013-10-13 20:21:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Wim Taymans 2016-08-22 06:32:34 EDT
I tried this (on Fedora):

On laptop (the sound production box):

  pacmd load-module module-native-protocol-tcp auth-anonymous=true

On Desktop:

  ssh -L 4713:localhost:4713 laptop
  
in another shell on Desktop:

  PULSE_SERVER=localhost:4713 ALSA_PCM_NAME=pulse padsp xterm

in the spawned xterm:

  mplayer /home/wim/data/serenity_1080p.mov

And then I get the sound on the laptop.

* You need to manually load module-native-protocol-tcp and enable anonymous 
  connections (or else copy over the cookies).
* 4713 is the default port, not 4716 for the native protocol.
* This should all be available in the default install.
* How did you set up things? what versions are server and client?
Comment 5 Jan Kurik 2017-12-06 06:35:00 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.