Bug 868129 - virt-v2v fails to convert linux guests to rhev
virt-v2v fails to convert linux guests to rhev
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 02:15 EDT by tingting zheng
Modified: 2013-02-21 05:59 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-v2v-0.8.9-2.el6
Doc Type: Bug Fix
Doc Text:
Documentation not required. This bug did not appear in RHEL.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:59:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Debug info from virt-v2v (448.58 KB, text/plain)
2012-10-19 02:18 EDT, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2012-10-19 02:15:31 EDT
Version-Release number of selected component (if applicable):
virt-v2v-0.8.9-1.el6
libguestfs-1.16.32-2.el6.x86_64
libvirt-0.10.2-4.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Use virt-v2v to convert a linux guest to rhev:
#virt-v2v -ic qemu+ssh://10.66.72.24/system -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm kvm-rhel6.2-i386-qcow2
kvm-rhel6.2-i386-qcow2.img: 100% [===============================================================================================================]D 0h01m46s
Undefined subroutine &Sys::VirtConvert::Connection::RHEVTarget::get_uuid called at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Connection/RHEVTarget.pm line 1042.

2.Downgrade virt-v2v to virt-v2v-0.8.7-6.el6.x86_64,it can convert a linux guest to rhev.
# virt-v2v -ic qemu+ssh://10.66.72.24/system -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm kvm-rhel6.2-i386-qcow2
kvm-rhel6.2-i386-qcow2.img: 100% [===============================================================================================================]D 0h01m59s
virt-v2v: kvm-rhel6.2-i386-qcow2 configured with virtio drivers.


Actual results:
virt-v2v fials to convert linux guest to rhev,error as step shows.

Expected results:
virt-v2v can convert linux guest to rhev successfully.

Additional info:
virt-v2v can convert linux guest to successfully.
Comment 1 tingting zheng 2012-10-19 02:18:26 EDT
Created attachment 629795 [details]
Debug info from virt-v2v
Comment 4 Matthew Booth 2012-10-19 08:45:46 EDT
This is fixed upstream.
Comment 6 yuping zhang 2012-10-25 02:41:10 EDT
Verified this issue with:
virt-v2v-0.8.9-2.el6.x86_64
libvirt-0.10.2-5.el6.x86_64
libguestfs-1.16.32-2.el6.x86_64

# virt-v2v -ic qemu+ssh://10.66.72.24/system -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm kvm-rhel6.2-x86_64-qcow2
root@10.66.72.24's password: 
root@10.66.72.24's password: 
kvm-rhel6.2-x86_64-qcow2.img: 100% [==============================================================================]D 0h01m35s
virt-v2v: kvm-rhel6.2-x86_64-qcow2 configured with virtio drivers.

Import the guest and start it. It works well.

So change the bug status to VERIFIED.
Comment 8 errata-xmlrpc 2013-02-21 05:59:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0477.html

Note You need to log in before you can comment on or make changes to this bug.