Bug 868149 - There are some suggestions in man config file and help info.
There are some suggestions in man config file and help info.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 03:15 EDT by Hui Wang
Modified: 2016-11-30 19:31 EST (History)
2 users (show)

See Also:
Fixed In Version: virt-who-0.8-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:50:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0374 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2013-02-20 15:52:26 EST

  None (edit)
Description Hui Wang 2012-10-19 03:15:02 EDT
Description of problem:
1. In virt-who man config file.
#man virt-who
 4. RHEV-M
 ^^^^^^^ 4
              # virt-who --rhevm --rhevm-owner=RHEVM_OWNER  --rhevm-env=RHEVM_ENV --rhevm-server=RHEVM_SERVER --rhevm-username=RHEVM_USERNAME
              --rhevm-password=RHEVM_PASSWORD

              Use RHEV-M as virtualization backend and specify option required to connect to RHEV-M server.

 4. Hyper-V
^^^^^^^^ 4
              #  virt-who  --hyperv   --hyperv-owner=HYPERV_OWNER    --hyperv-env=HYPERV_ENV   --hyperv-server=HYPERV_SERVER   --hyperv-user-
              name=HYPERV_USERNAME --hyperv-password=HYPERV_PASSWORD

              Use Hyper-V as virtualization backend and specify option required to connect to Hyper-V server.



2. About RHEV-M backend, "virt-who --help"


 --rhevm-server=SERVER
                        URL of the RHEV-M server to connect to

^^^^^^^^^^^^^^There are two URL can connect to RHEVM manager, http://$IP:port1, https://$IP:port2(security)
Actually, virt-who support secure URL should be $ip:port2. Pls provide suitable notice to the customer.

    --rhevm-username=USERNAME
                        Username for connecting to RHEV-M
^^^^^^^^^^^^^^Actually, the USERNAME should be $username@domain of RHEV-M manager, pls add suitable notice.

Version-Release number of selected component (if applicable):
virt-who-0.8-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
As the description

Expected results:
1.  4. Hyper-V
^^^^^^^^ 5. Hyper-V
2. Give suitable descriptions of --rhevm-server=SERVER and --rhevm-username=USERNAME

Additional info:
Comment 1 Radek Novacek 2012-10-24 04:43:26 EDT
This bug has been fixed in virt-who-0.8-4.el6.
Comment 3 Hui Wang 2012-10-24 06:16:00 EDT
Verified the bug, the result is PASS.

version:
virt-who-0.8-4.el6.noarch.rpm

Moving the status to VERIFIED
Comment 5 errata-xmlrpc 2013-02-21 04:50:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0374.html

Note You need to log in before you can comment on or make changes to this bug.