Bug 8682 - Missing translating files
Summary: Missing translating files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-20 22:22 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 16:13:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff against texinfo-4.0-2 spec-file (2.00 KB, patch)
2000-01-20 22:25 UTC, Enrico Scholz
no flags Details | Diff

Description Enrico Scholz 2000-01-20 22:22:21 UTC
texinfo contains the possibility to translate some tags (e.g. the headings)
by using the @documentlanguage command; but the needed txi-*.txi files are
missing.

While building a RPM including these files I ran into the problem that the
tetex package brings its own texinfo.tex which conflicts with my
enhancements. Because the tetex-texinfo version seems to be obsoleted and
doesn't contains the other I think the standalone texinfo-package should
provide all needed files including texinfo.tex.

I will send the diffs against the spec-file of 4.0-2 which solves bug #6632
by the way...

Comment 1 Enrico Scholz 2000-01-20 22:25:59 UTC
Created attachment 72 [details]
Diff against texinfo-4.0-2 spec-file

Comment 2 Bernhard Rosenkraenzer 2000-01-26 11:43:59 UTC
Thanks - I've fixed the info-stnd stuff (somewhat different from what you
suggested though).
As for the txi stuff, the reason why they aren't included is the conflict with
tetex; I'd rather have tetex updated with the current files from texinfo than
moving them out of tetex and putting them into texinfo.
Assigning this to the owner of tetex...

Comment 3 Tim Waugh 2001-04-06 16:58:59 UTC
Just so I'm absolutely clear: which files exactly need updating?  I think it's

/usr/share/texmf/tex/texinfo/txi-*.tex
/usr/share/texmf/tex/texinfo/texinfo.tex

with additional files:

/usr/share/texmf/tex/texinfo/epsf.tex
/usr/share/texmf/tex/texinfo/config/texinfo.cnf

Is that right?


Comment 4 Enrico Scholz 2001-04-06 17:43:39 UTC
Yes; the first two files are in current tetex already.

The location of 'texinfo.cnf' is variable as long it is under the texmf-root and
has been seen by the 'texhash' command. I have choosen the 'config' subdir
because the other TeX modules are using it also.

Comment 5 Tim Waugh 2001-04-11 12:59:06 UTC
Okay, in fact it looks like just updating the texinfo in the tetex SRPM to the 
current texinfo (as well as adding those two files to the manifest) will fix 
this.


Comment 6 Tim Waugh 2001-04-11 14:31:07 UTC
If the texinfo.cnf is left out, is that a huge problem?  I think that texinfo 
rather than tetex should provide that, if at all.


Comment 7 Enrico Scholz 2001-04-11 15:24:26 UTC
I would like to see it as a template where the user can make its changes.
Because the documentation does not say something about the place/directory where
this file should be located, a standard texinfo.cnf in the distribution would
give an hint where it can be expected on a RH system.

But if it does not fit into current packages, you can omit it...

Comment 8 Tim Waugh 2001-04-11 16:13:14 UTC
Now that I look more closely at this, these seem up to date already:

/usr/share/texmf/tex/texinfo/txi-*.tex
/usr/share/texmf/tex/texinfo/texinfo.tex



Comment 9 Tim Waugh 2001-04-19 09:29:38 UTC
Fixed in tetex-1.0.7-16.



Note You need to log in before you can comment on or make changes to this bug.