Bug 868218 - semanage man page and help are inconsistent (role/roles)
Summary: semanage man page and help are inconsistent (role/roles)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils
Version: 6.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Michal Trunecka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-19 09:54 UTC by Michal Trunecka
Modified: 2014-09-30 23:33 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.0.83-19.34.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 11:06:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1608 normal SHIPPED_LIVE policycoreutils bug fix and enhancement update 2013-11-20 21:39:06 UTC

Description Michal Trunecka 2012-10-19 09:54:47 UTC
Man page contains:
       -R, --role
              SELinux Roles.  You must enclose multiple roles  within  quotes,
              separate by spaces. Or specify -R multiple times.

Help contains:
	-R, --roles      SELinux Roles (ex: "sysadm_r staff_r")

As the program searches for the prefix in options, this is not a bug, only documentation issue.


Version-Release number of selected component (if applicable):
RHEL6.4-20121011.n.0

Steps to Reproduce: 
Compare   semanage -h    and    man semanage


Actual results: 
-R --rule(s) inconsistent

Expected results:
consistent option

Comment 2 Miroslav Grepl 2012-11-16 09:02:40 UTC
Yes, you can see the same for more options. Basically "man page" contains more detailed info.

Comment 3 Michal Trunecka 2013-08-20 09:06:46 UTC
This issue is not about the text, but about the long option. Once it is --role and once --roles (with 's').

Comment 4 RHEL Product and Program Management 2013-09-05 10:40:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 7 errata-xmlrpc 2013-11-21 11:06:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1608.html


Note You need to log in before you can comment on or make changes to this bug.