Bug 868230 - colord and cross-dependencies
colord and cross-dependencies
Status: CLOSED DUPLICATE of bug 849065
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-10-19 06:17 EDT by Harald Reindl
Modified: 2012-10-21 13:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-21 09:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2012-10-19 06:17:36 EDT
it would be really nice to relax the depenency-tree added in F17
"php-pecl-imagick" finally pulls gtk3, colord and X11 stuff
which does not satisfy a server-admin

LANG=en; yum remove colord
Failed to set locale, defaulting to C
Loaded plugins: downloadonly, protectbase
Resolving Dependencies
--> Running transaction check
---> Package colord.x86_64 0:0.1.23-1.fc17 will be erased
--> Processing Dependency: libcolord.so.1()(64bit) for package: gtk3-3.4.4-1.fc17.x86_64
--> Running transaction check
---> Package gtk3.x86_64 0:3.4.4-1.fc17 will be erased
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: librsvg2-2.36.1-1.fc17.x86_64
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: librsvg2-2.36.1-1.fc17.x86_64
--> Running transaction check
---> Package librsvg2.x86_64 0:2.36.1-1.fc17 will be erased
--> Processing Dependency: librsvg-2.so.2()(64bit) for package: ImageMagick-
--> Running transaction check
---> Package ImageMagick.x86_64 0: will be erased
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: 3:php-pecl-imagick-3.0.1-22.fc17.20121019.rh.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: 3:php-pecl-imagick-3.0.1-22.fc17.20121019.rh.x86_64
--> Running transaction check
---> Package php-pecl-imagick.x86_64 3:3.0.1-22.fc17.20121019.rh will be erased
Comment 1 Pavel Alexeev 2012-10-21 09:23:24 EDT
php-pecl-imagick explicit require only php (php-api) all other is auto dependencies by linked libraries. I think there nothing to fix.

Please reopen if you have real suggestions how to deal with it.
Comment 2 Harald Reindl 2012-10-21 11:21:20 EDT
correct: "php-pecl-imagick" requires only php and imagemagick but imagemagick pulls in colord and finally GTK3 resulting in pulling xorg-dependencies

so you have a huge overhead of dependencies completly unneeded on a server which will never talk to X nor do 99 out of 100 users needs coolord at all (even on a desktop)
Comment 3 Pavel Alexeev 2012-10-21 13:05:05 EDT
>correct: "php-pecl-imagick" requires only php and imagemagick
ImageMagick required automatically by library dependencies.

I think in such discussion it will ImageMagick issue and its reported separately (but stalled) - 849065

*** This bug has been marked as a duplicate of bug 849065 ***

Note You need to log in before you can comment on or make changes to this bug.