Bug 868237 - spice-gtk sends 00 scancodes to inputs_scancode capable vms
spice-gtk sends 00 scancodes to inputs_scancode capable vms
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 880883 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 06:23 EDT by Hans de Goede
Modified: 2013-07-03 08:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:49:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-10-19 06:23:32 EDT
spice-gtk sends 00 scancodes to inputs_scancode capable vms

This results in the following in dmesg of Linux guests:
atkbd serio0: Unknown key pressed (translated set 2, code 0x0 on isa0060/serio0).
atkbd serio0: Use 'setkeycodes 00 <keycode>' to make it known. 

To reproduce this take the latest 6,4 spice-server + spice-gtk, run a Linux guest,
press a key in a spice-gtk based client and then look in dmesg.

There is a patch upstream fixing this:
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=eec5f937150e9bc65e02b80ea06bd4bad3a90978
Comment 1 Marc-Andre Lureau 2012-12-10 08:05:49 EST
Fixed in spice-gtk-0.14-5.el6
Comment 5 errata-xmlrpc 2013-02-21 03:49:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html
Comment 6 Marc-Andre Lureau 2013-05-29 07:39:58 EDT
*** Bug 880883 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.