Bug 868258 - [storage.py]Using function "check_partition_sizes" failed to check "ROOTDRIVESPACE" is enough for "ROOT_NEED_SIZE"
[storage.py]Using function "check_partition_sizes" failed to check "ROOTDRIVE...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 07:10 EDT by haiyang,dong
Modified: 2013-02-28 11:41 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, if the desired root filesystem size was larger than the actual root partition during an automated Hypervisor installation, the installation failed without providing useful information as to why in the log file. Now, if the desired root filesystem is larger than the actual root partition, the installation failure message clearly states that the partition is too small.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:41:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached the ovirt.log.try1 (39.40 KB, application/octet-stream)
2012-10-19 07:13 EDT, haiyang,dong
no flags Details
attached the ovirt.log.try2 (6.13 KB, application/octet-stream)
2012-10-19 07:13 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-10-19 07:10:25 EDT
Description of problem: 
function "check_partition_sizes" provided the following two functions:
1.Check whether "HOSTVGDRIVESPACE" is enough or not for "HOSTVG_NEED_SIZE"
2.Check whether "ROOTDRIVESPACE"" is enough or not for "ROOT_NEED_SIZE"

Try:
1. when configured the ROOT Space > /dev/sdb
/dev/sdb:4G
 /dev/sdc:16G
 Auto install RHEV-H with "storage_init=/dev/sdb,/dev/sdc storage_vol=2048:4096:4096:2048:2048:2048
Auto install failed, but no valuable information in ovirt.log.try1,

2.when configure the HOSTVG Space > /dev/sdc
/dev/sdb:4G
/dev/sdc:4G
Auto install RHEV-H with "storage_init=/dev/sdb,/dev/sdc storage_vol=:4096::2048:2048:2048"

Auto install failed, can seen valuable information like this in ovirt.log.try2:
2012-10-19 09:59:40,422 - DEBUG - storage - Getting Drive Size For: /dev/sdb
2012-10-19 09:59:40,426 - DEBUG - storage - 3821
2012-10-19 09:59:40,426 - DEBUG - storage - Getting Drive Size For: /dev/sdc
2012-10-19 09:59:40,431 - DEBUG - storage - 3827
2012-10-19 09:59:40,431 - ERROR - storage - The target storage device is too small for the desired sizes:
2012-10-19 09:59:40,431 - ERROR - storage -  Disk Target: HOSTVG
2012-10-19 09:59:40,431 - ERROR - storage -  Size of target storage device: 3827MB
2012-10-19 09:59:40,431 - ERROR - storage -  Total storage size to be used: 10240MB
2012-10-19 09:59:40,431 - ERROR - storage - You need an additional 6413MB of storage.

so that
function "check_partition_sizes" success to check "HOSTVGDRIVESPACE" is enough or not for "HOSTVG_NEED_SIZE"

But function "check_partition_sizes" failed to check "ROOTDRIVESPACE" is enough or not for "ROOT_NEED_SIZE"

Version-Release number of selected component (if applicable): 
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible: 
100% 

Steps to Reproduce: 
1.
/dev/sdb:4G
/dev/sdc:16G
Auto install RHEV-H with "storage_init=/dev/sdb,/dev/sdc storage_vol=2048:4096:4096:2048:2048:2048"
2.
/dev/sdb:4G
/dev/sdc:4G
Auto install RHEV-H with "storage_init=/dev/sdb,/dev/sdc storage_vol=:4096::2048:2048:2048"

Actual results: 
Using function "check_partition_sizes" failed to check whether "ROOTDRIVESPACE" is enough or not for "ROOT_NEED_SIZE"

Expected results: 
Using function "check_partition_sizes" success to check whether "ROOTDRIVESPACE" is enough or not for "ROOT_NEED_SIZE"

Additional info: 
----------
Comment 2 haiyang,dong 2012-10-19 07:13:24 EDT
Created attachment 629931 [details]
attached the ovirt.log.try1
Comment 3 haiyang,dong 2012-10-19 07:13:53 EDT
Created attachment 629932 [details]
attached the ovirt.log.try2
Comment 6 haiyang,dong 2012-12-19 05:59:42 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Tested as follows:
when configured the ROOT Space > /dev/sdb
/dev/sdb:4G
 /dev/sdc:16G
 Auto install RHEV-H with "storage_init=/dev/sdb,/dev/sdc storage_vol=2048:4096:4096:2048:2048:2048
Auto install failed, can seen valuable information like this:
ERROR:ovirtnode.storage:The target storage device is too small for the desired sizes:
ERROR:ovirtnode.storage: Disk Target: Root
ERROR:ovirtnode.storage: Size of target storage device: 3821 MB
ERROR:ovirtnode.storage: Total storage size to be used: 8192 MB
ERROR:ovirtnode.storage: You need an additional 4371 MB of storage.

so this bug has been fixed, change the status into "VERIFIED"
Comment 8 errata-xmlrpc 2013-02-28 11:41:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.