Bug 868286 - confusing and unnecessary messages during katello-service run
confusing and unnecessary messages during katello-service run
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Suchý
Katello QA List
: Triaged
Depends On:
Blocks: sam13-tracker 876323
  Show dependency treegraph
 
Reported: 2012-10-19 08:17 EDT by Tom McKay
Modified: 2013-10-01 06:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: elasticsearch-0.19.9-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 876323 (view as bug list)
Environment:
Last Closed: 2013-10-01 06:52:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
katello-service (13.37 KB, image/png)
2012-10-19 08:17 EDT, Tom McKay
no flags Details

  None (edit)
Description Tom McKay 2012-10-19 08:17:31 EDT
Created attachment 629999 [details]
katello-service

During 'katello-service restart' INFO messages are displayed (see attached screenshot). I have two issues with this:

1. The INFO is not at all informational or useful, as far as I can tell. It would be better just to state OK on success.

2. Each run seems to print a different name in the INFO message. In this case it was "Zero-G" which no one understands the significance. (Working with a customer we were unable to answer what it was or meant.) The next run I did the string was "Firefrost". This is a pointless confusion.
Comment 2 Miroslav Suchý 2012-10-19 08:41:11 EDT
This only happen on RHEL6 as on fedora this is eaten by systemd who redirect it to log.
And that verbose output is written by thin.
Comment 3 Miroslav Suchý 2012-11-13 06:11:06 EST
Fixed in katello-thirdparty.git
* 3c1ae73 868286 - do not be verbose during startup
Comment 4 Bryan Kearney 2013-06-07 14:20:07 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 5 sthirugn@redhat.com 2013-08-11 20:51:11 EDT
Verified.

# katello-service restart
Shutting down Katello services...
Stopping katello: 
Stopping elasticsearch: [  OK  ]
Stopping thumbslug: [  OK  ]
Stopping httpd: [  OK  ]
Stopping tomcat6: [  OK  ]
Done.
Starting Katello services...
Starting tomcat6: [  OK  ]
Starting httpd: [  OK  ]
Starting thumbslug: Aug 11 20:47:52 [main] WARN  org.candlepin.thumbslug.Main - Shutting down...
[  OK  ]
Starting elasticsearch: [  OK  ]
Starting katello: [  OK  ]
Starting katello-jobs: [  OK  ]
Done.

I did not see the INFO messages as mentioned originally in this bug.

Package Verified:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 7 errata-xmlrpc 2013-10-01 06:52:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.